really annoying KDE window focus bug

Using focus follow mouse / under mouse / strictly, if you pass over a 3rd window while passing from source to target window, then the between window is nearly always left with the focus, even while using strictly under mouse. It’s a true pita bug, I’m often typing in the wrong window. I am forced to double check the active window and / or just click all the time, like it’s click-to-focus. It’s been like this for a while. Is there an easy way to resolve it?

I think the problem is that the “title bar fade” animation is busy on the between window, while the mouse enters the final window. Changing from Breeze to Plastik window decorations makes harder to trigger. Breeze definitely has a hard coded animation. Ugh, I’m seeing focus snap back to the original wind with Plastik, okay that’s down right nasty.

Have you tried to disable it then?
I’m currently not sure if there’s an explicit option, or what exactly you mean, but you can try disabling desktop effects completely (e.g. press Shift+Alt+F12).

I cannot comment on the issue itself, as I never used “Focus Follow Mouse” (or under mouse/strictly) and don’t intend to either.

Might be worth a bug report at though.

I don’t use your setting, instead i use & really like] “Focus Follows Mouse - Mouse Precedence”. Does this one really not suit your tastes?

I tried all 3 or 4 “follow mouse” options. It’s not that I don’t like them, I’m saying they are all buggy, and the focus is not under the mouse. Particularly “focus strictly under the mouse” (classic X11 / twm circa 1995) is obviously broken. And I wind up having to click-to-focus anyway. I tried several themes, it’s not the title bar fade I don’t think, it’s just plain buggy.