Real Player issue in FF, Opera - but not K

Using my Lenovo R61e laptop. Celeron 32 bit

Going to bbc weather: BBC - Weather Centre - World Weather

watch and listen
opens real player starts buffering, then the player just goes all white.

I have everything in place. All mutimedia works fine.

Only thing I have not tried is a real media file from the HD, because I don’t have one to hand.

Should have stated some obviously omitted points:

OS11
kde3 build service
plugins are listed in all browsers - as already mentioned they player starts, buffers, then it all goes white.

Though I have found a .rmvb file and it starts to open then closes.

Real player opens from the menu
And as already mentioned - using konqueror to bbc is fine.

Hmmm … when launching the bbc weather site to play the “bbc weather player” one is given a choice to either launch “Windows Media Player” or launch “Realplayer”. I chose “Windows Media Player” when visiting that site from Firefox, and that launches mplayerplug-in which plays fine.

Further to this, I went and cleared my cookies for bbc weather site, and then visited the site again, this time selecting “realplayer” media stream. Again, my firefox browser launched “mplayerplug-in” which played with no problem.

I do have RealPlayer-10.0.9-11 installed, but I find with the functionality provided by mplayerplug-in (and MPlayer) I can play the video streams with no problems and hence I do not have my firefox setup to call RealPlayer.

I have real player functionality working on my main box as ref in my sig.
Vitually all my settings in my Laptop are set the same as my box. Only difference is Intel and 32 bit on Laptop

I’ll continue to fiddle with this, thanks for your input oldcpu

oldcpu.
I installed the mplayer plugin but basically get the same result with that. It’s almost as if it starts to play and there is no data there.

It’s rather odd. I’m starting to wonder if it could be related to video. I have NO issues otherwise. This laptop just seemed to work out of the box and flash is just fine too.

Is your setup 64-bit or 32-bit ? Mine is 32-bit and it “just works”.

32 bit as quoted above earlier

It’s my _64 main box that works ok

My laptop 32 bit doesn’t.

When I type

about:plugins

in firefox’s location bar, it is clear it will launch mplayerplug-in for .rm files, and the BBC web site streams a .rm file.

I tested this on both my openSUSE-10.3 PC (with KDE-3.5.7 on an Athlon-2800) and on my openSUSE-11.0 PC (with KDE-3.5.9 on an Athlon-1100) and both “just work”.

One note, the mplayerplug-in first spends some time buffering the .rm file, before it starts to play the file.

Friend, thanks for all your help.

I removed the Real Player from the suse repo.

And downloaded and ran the latest installer .bin ver. 11
And it’s working now.

I must admit I seldom use Realplayer, it seems far less popular these days and flash seems to be the norm in most places, the bbc have the weather avail in flash but not all the time and not so up to date, as it come via iPlayer, which they are a bit slow getting stuff on at times.