Ready to Installl 15.3, I think, but questions first

I was happily using leap up to 15.1. Then, silly me, I tried an upgrade to 15.2 without reading that I had to do a full install. never got those problems resolved…one of which is the Neuveau drivers. Time to move on. I’m going to do a full install of 15.3 on a separate drive and then put my data back and hopefully, all will go well.

I do not do gaming, so I don’t have a high end video card and the one I’m using is an Nvidia card. Back in 15.1 I was using the Neuveau driver and all was well. Before I do the installation I want to know if I should get a new video card and if so, which will be usable without the problems I have had with Neuveau?

Thank you for any suggestions,


Hi Mark,

I’m still on 15.2 but I think I can share some ideas:
The major trouble with old nvidia cards was upgrade to 15.2 where the G03 driver is not available anymore. If your card worked there I think it should be fine in 15.3, too. To be sure, you may share more info on your hardware and your current setup.

I’m going to do a full install of 15.3 on a separate drive and then put my data back and hopefully, all will go well.

Well, a full backup of /home/ would be best. Then, I’d check if you have /home/ on a separate partition. In that case you can do your new install and tell the installer to use your exisiting /home/. Make sure to not format it in the settings of expert partitioner.

Your data will be preserved, settings used and new software setting will be updated. If you use Kontact / Akonadi you may wish to check if it is using mysql or mariadb. There’s some threads here with issue that mysql got replaced be mariadb. That shouldn’t be an issue but for downward compatibilty. It wouldn’t harm you anyway. You have backed-up you /home/!

Ah, and be aware that 15.3 is now getting updates from SLE repos. Others can share there actual experience with the upgrade.

After all, the release notes are quite important for this version.

Have a lot of fun!


Thank you for your kind words. I still have the one question of should I replace my video card and if so, with what?

Many thanks,

You have to decide for yourself whether it is worth replacing your video card. I can only tell you that I avoid Nvidia because a large part of the topics here in the forum relate to their graphic cards. However if you are happy with the noveau driver you could always fall back to that driver with the nomodeset option in GRUB. Although I am not an IT person I have become the maintainer of our small network of 5 computers, one Tumbleweed and the rest Leap now all upgraded to 15.3. 4 of the 5 computers computers have intel graphics and I never had problems with them They always seem to grab the relevant driver during install and upgrade and just work. One computer is 15 years old (without intel graphics see the topic here “upgrade from 15.2 - no GUI” and when I have to replace it I make sure again that it will have intel graphics.

“nomodeset” in GRUB disables nouveau driver. Get your facts right.

System details always matter. Show your system as follows:

**3400G:~ #** inxi -zFm             
**System:    Kernel:** 5.12.12-1-default x86_64 **bits:** 64 **Console:** tty pts/1 **Distro:** openSUSE Tumbleweed 20210625  
**Machine:   Type:** Desktop **Mobo:** ASUSTeK **model:** PRIME B450-PLUS **v:** Rev X.0x **serial:** <filter> **UEFI:** American Megatrends **v:** 2409  
           **date:** 12/02/2020  
**Memory:    RAM:****total:** 29.27 GiB **used:** 2.33 GiB (8.0%)  
           **Array-1:****capacity:** 128 GiB **slots:** 4 **EC:** None  
           **Device-1:** DIMM_A1 **size:** No Module Installed  
           **Device-2:** DIMM_A2 **size:** 16 GiB **speed:** 2133 MT/s  
           **Device-3:** DIMM_B1 **size:** No Module Installed  
           **Device-4:** DIMM_B2 **size:** 16 GiB **speed:** 2133 MT/s  
**CPU:       Info:** Quad Core **model:** AMD Ryzen 5 3400G with Radeon Vega Graphics **bits:** 64 **type:** MT MCP **cache:****L2:** 2 MiB  
           **Speed:** 1462 MHz **min/max:** 1400/3700 MHz **Core speeds (MHz):****1:** 1462 **2:** 1258 **3:** 1324 **4:** 1313 **5:** 1261 **6:** 1236 **7:** 1257  
           **8:** 1259  
**Graphics:  Device-1:** Advanced Micro Devices [AMD/ATI] Picasso **driver:** amdgpu **v:** kernel  
           **Display:****server:** X.Org 1.20.11 **driver:****loaded:** amdgpu,ati **unloaded:** fbdev,modesetting,vesa  
           **resolution:** 1920x1080~60Hz  
           **OpenGL:****renderer:** AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.12.12-1-default LLVM 12.0.0) **v:** 4.6 Mesa 21.1.3  
**Audio:     Device-1:** Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio **driver:** snd_hda_intel  
           **Device-2:** Advanced Micro Devices [AMD] Family 17h HD Audio **driver:** snd_hda_intel  
           **Device-3:** Tenx USB AUDIO **type:** USB **driver:** hid-generic,snd-usb-audio,usbhid  
           **Sound Server-1:** ALSA **v:** k5.12.12-1-default **running:** yes  
           **Sound Server-2:** PulseAudio **v:** 14.2-rebootstrapped **running:** yes  
**Network:   Device-1:** Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet **driver:** r8169  
           **IF:** eth0 **state:** up **speed:** 100 Mbps **duplex:** full **mac:** <filter>  
**Drives:    Local Storage:****total:** 2.5 TiB **used:** 1.55 TiB (61.9%)  
           **ID-1:** /dev/sda **vendor:** Seagate **model:** ST2000DM001-1CH164 **size:** 1.82 TiB  
           **ID-2:** /dev/sdb **vendor:** Samsung **model:** SSD 850 EVO 500GB **size:** 465.76 GiB  
           **ID-3:** /dev/sdc **vendor:** Samsung **model:** SSD 850 EVO 250GB **size:** 232.89 GiB  
**Partition: ID-1:** / **size:** 40 GiB **used:** 29.68 GiB (74.2%) **fs:** btrfs **dev:** /dev/sdc3  
           **ID-2:** /boot/efi **size:** 99.8 MiB **used:** 31.6 MiB (31.7%) **fs:** vfat **dev:** /dev/sdc1  
           **ID-3:** /home **size:** 427.82 GiB **used:** 344.63 GiB (80.6%) **fs:** ext4 **dev:** /dev/sdb3  
           **ID-4:** /opt **size:** 40 GiB **used:** 29.68 GiB (74.2%) **fs:** btrfs **dev:** /dev/sdc3  
           **ID-5:** /var **size:** 40 GiB **used:** 29.68 GiB (74.2%) **fs:** btrfs **dev:** /dev/sdc3  
**Swap:      Alert:** No Swap data was found.  
**Sensors:   System Temperatures:****cpu:** 41.2 C **mobo:** N/A **gpu:** amdgpu **temp:** 41.0 C  
           **Fan Speeds (RPM):** N/A  
**Info:      Processes:** 305 **Uptime:** N/A **Shell:** Bash **inxi:** 3.3.03  
**3400G:~ #**

I too have had major issues with nvidia proprietary drivers. But, I am past them.

If you are doing a fresh install of 15.3 you will have the system nouveau drivers by default. You can’t install nvidia drivers through install disk process. Separate license confirmation is needed before installing them…

There is an option to not use the mesa-nouveau in the15.3 install process, I took that option. Your system should run fine after install using the system default drivers. I have tabooed (in yast software manager) the mesa-dri-nouveau driver to keep it out of the way. That is the one you declined to install in the install dialogue.

If you wish to try the proprietary nvidia drives, that is a separate step. I can’t say whether there would be any performance improvement on your older card. Perhaps the “stock” drivers would be acceptable to you.

There are docs related to the “easy” way and the “hard” way to install nvidia proprietary drivers. Read them before starting changeover to nvidia.

I have an nvidia GeForce GTX 1050 ti card that works fine for me. Uses G05 level drivers. I don’t do games though. I do scientific work and graphs and astronomical photos are to me acceptable on this card at 1920x1080 resolution. This is mid level card (now out of date probably).

I would try what you have and you can later upgrade card if you wish.

Tom kosvic

As you requested:

#mark:~ # inxi
CPU: Quad Core Intel Core i5-2500K (-MCP-) speed/min/max: 2611/1600/3700 MHz Kernel: 5.3.18-lp152.78-default x86_64 
Up: 10h 07m Mem: 4918.2/15987.8 MiB (30.8%) Storage: 1.13 TiB (21.3% used) Procs: 264 Shell: bash 4.4.23 inxi: 3.1.00 
mark:~ # inxi -zFm
System:    Kernel: 5.3.18-lp152.78-default x86_64 bits: 64 Console: tty 4 Distro: openSUSE Leap 15.2 
Machine:   Type: Desktop System: MSI product: MS-7673 v: 2.0 serial: N/A 
           Mobo: MSI model: P67A-G43 (MS-7673) v: 2.0 serial: N/A BIOS: American Megatrends v: 1.9 date: 03/02/2011 
Memory:    RAM: total: 15.61 GiB used: 4.81 GiB (30.8%) 
           Array-1: capacity: 32 GiB slots: 4 EC: None 
           Device-1: A1_DIMM0 size: 4 GiB speed: 1333 MT/s 
           Device-2: A1_DIMM1 size: 4 GiB speed: 1333 MT/s 
           Device-3: A1_DIMM2 size: 4 GiB speed: 1333 MT/s 
           Device-4: A1_DIMM3 size: 4 GiB speed: 1333 MT/s 
CPU:       Topology: Quad Core model: Intel Core i5-2500K bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1650 MHz min/max: 1600/3700 MHz Core speeds (MHz): 1: 1811 2: 2011 3: 1918 4: 1866 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: N/A 
           Display: server: X.Org 1.20.3 driver: nouveau,nv FAILED: nvidia unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~77Hz 
           OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.3.2 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel 
           Sound Server: ALSA v: k5.3.18-lp152.78-default 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 245.65 GiB (21.3%) 
           ID-1: /dev/sda model: SATA SSD size: 223.57 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD1003FZEX-00MK2A0 size: 931.51 GiB 
Partition: ID-1: / size: 211.71 GiB used: 47.00 GiB (22.2%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 264 Uptime: 10h 07m Shell: bash inxi: 3.1.00 
mark:~ # 

***See below!!! Sorry, I didn’t trim the first 3 lines when I just tried #inxi.