Read Write to NTFS

I have just installed OpenSuse 12.2 on a new hard drive.
It has two NTFS partitions on it that I want access to from from OpenSuse.
At the moment I can read from the partitions but cant write to them.
The current fstab looks similar to my old one.

/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part6 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part7 /home                ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part4 /Shared              ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part2 /Windows             ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0

Any idaes?
Thanks for any help

You need to change the permissions for the two partitions. For example, you can replace

/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part4 /Shared ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0


/dev/disk/by-id/ata-WDC_WD7500BPKT-00PK4T0_WD-WX31C62M7758-part4 /Shared ntfs-3g defaults,locale=en_GB.UTF-8 0 0

And I do not know if you recreated those two mount points, but you should also check their owners and access bits.

Thanks for that guys, I’ll try that when I get home from work.
hcvv, how do I do that?
Is there a site with details on what each part of fstab does? I’m sure many years ago I found a description, but I haven’t been able to find.
Thanks again.

Like most documentation about basix Linux tools and configuration files, it is on your system:

man fstab


man mount

are the starting points in this case.
(You can also start Konqueror and use #fstab and *#mount *in the address bar, nice reading.

And to see who is the owner and what are the access bits of a file, use* ls*

ls -ld /Shared /Windows

I have changed the permissions as suggested by billypap. This seems to have solved my problem.

ls -ld /Shared /Windows
drwxrwxrwx 1 root root  4096 Sep 11 07:27 /Shared
drwxrwxrwx 1 root root 12288 Sep  8 09:58 /Windows

Is this ok?

Please, when you are managing a Linux system, do try to read something about ownership by user and group and the access-bits of files. Very crucial to your understanding.

As you have it now, everybody that has access to your system (can login, to put it short) can read write and search in those directories. That might be OK, but it is not us that have to decide if it is realy OK. It could e.g. be that only one particular user must have access. In that case it would be better to make that user (and his/her group) owner of the directories. And that user can then themselve see what read/write/execute access he/she want to grant to themselve his/her fellow group members and the other users. But again, you design the policy, not we. We can only tell you how to get organised what you want to do (when you doubt yourself on the implementation of the policy).

On 09/10/2012 07:56 PM, hcvv wrote:
> As you have it now, everybody that has access to your system (can
> login, to put it short) can read write and search in those directories.

yep…folks who rush to solve “permissions problems” by granting
everyone permission to read, write, execute/browse are just asking for
a breach!


That is true, the ‘defaults’ settings was merely a suggestion that would remove the write limitations. I only use that since I have one ‘public’ partition used as a library for music, movies, etc. Permissions is indeed a very important part of linux systems, I should have been a bit more careful with my reply.

However, in the case of a windows installation partition, what would you suggest ? Giving permissions to a new group, something like ‘windows-admins’ ?

I have a single user system that myself and my wife uses. As you can can see I have windows installed (for itunes and other software that I use every now and then). Maybe I should set up a guest user account for others. I have the “Shared” partition to share music and other files between the two operating systems.
I had a look at the man pages, but to be honest, I struggle to understand them (its sad,… I know).
For me to learn this I need to have time to sit down and fiddle with it. That was fine when I was single and Linux was not my main operating system. But now I am married with kids, Opensuse is my operating system and I need to have a stable working computer (the reason I left windows in the first place)
I can be a bit slow sometimes. Please be patient with me :slight_smile:
Thanks again for your help.

From a Unix/Linux point of view that is completely wrong. Not as bad as use user root for the wrong things, but almost. Unix/Linux are multi user operating systems. Every user has her/his own settings, mail, secrets, preferences. When your wife wants to use Gnome, while you are a KDE fan, or you want football shortcuts on your desktop and your wife cooking web-sites, how do you cope? That is one of the silly things of Windows, that it it makes your sysem to a truly Personal Computer (stress on Personal).

And when you want to share things (like music) there is the group allowances for doing that. And symbolic links to make it easy to use them from a convenient place in a users home directory.

@billypap, your initial solution was good enough imho. But when @asarge then asked us if his setup was OK, then then my answer was: “OK for what?” It solved his original problem, but in a way like: “I can not get my car through the gate, it is closed”. Answer: "“Remove the gate”. It works. but it is up the owner of the piece of land, if this is the correct solution or if providing a key to somebody is better. rotfl!

And yes, the fact that this is about a windows file system on an also Windows bootable sytem, makes all security considarations futile.

I tried a couple of years ago setting up an account for my wife, but she just kept logging into mine. We use a lot of the same files and I didn’t know that we are able to share them. I have more learning to do.
Are there any simplified man pages online with pictures/diagrams and examples? Lol it they were written like hcvv’s last post I would understand them better. :slight_smile:

When your wife logs in with your username, you did not keep your password secret enough. That is completely your fault. And you deserve that she realy completely borks your home directory. >:)

And of course, when you want to know more about a subject, it is not difficult for mosts people to search the Internet. And for serious knowledge there is also Wikipedia: Filesystem permissions - Wikipedia, the free encyclopedia

Come on! A little bit of assertive initiative of yourself.

So… am I reading this right

sarge@sarge:~> ls -ld /Shared /Windows
drwxrwxrwx 1 root root  4096 Sep 11 07:27 /Shared
drwxrwxrwx 1 root root 12288 Sep  8 09:58 /Windows

Both of the partitions are being treated as directories (d)
User, Group & all others have read, write & execute permissions in both of the partitions
And this is Symbolic notation?

And in the fstab file

ntfs-3g    users,gid=users,fmask=**133**,dmask=**022**,locale=en_GB.UTF-8 0 0

Is this the Octal notation?

Is this how I should be changing permissions?
Or have I just really embarrassed myself by reading this totally wrong?

Yeap, you are reading everything fine. Check this too if you like, just to make sure

You are getting nearer to it IMHO. :wink:

But your language is still a bit … e.g.

Both of the partitions are being treated as directories

shows to me that you do not realy know what “mounting” a file system is (you do not mount a partition, you mount the file system). And those directories are not “treated as” directories, they are directories. They are created as such, no special treatment. And you can mount a file system on every directory you have.

Thus for example, as a file system contains a lot of music MP3 files owned by user musiclover, you could mount it at /home/musiclover/music. And he/she will “see” these music files from there further in the directory tree, like /home/musiclover/music/Shubert/Unvollendete.mp3. Or from his/her own view, down from his/her Home directory: music/Schubert/Unvollendete.

More about the subject here: SDB:Basics of partitions, filesystems, mount points - openSUSE

I have changed my fstab back to the original.
I now get

sarge@sarge:~> ls -ld /Shared /Windows
drwxr-xr-x 1 root users  4096 Sep 12 17:00 /Shared
drwxr-xr-x 1 root users 12288 Sep 12 17:00 /Windows

Now I need to give myself permission to read, write & execute from these file systems. Well, I probably don’t need to execute.
Is this able to be done through YaST User and group management? (looking for the easy way out)

Looking at what I changed between not having permission and everyone having permission, all that was removed was


I haven’t been able to find anything useful on this yet.

Now I have found
So should I attempt to set up a user group that is allowed access to the ntfs file system?

I think that using th parameter defaults instead of all you have may help.

And please show your fstab entry completely everytime you want to say something about it. Else we have to search back to all of the thread and hope that you still have what we find and do not i=overlook some piece of your story.

On 2012-09-13 14:16, asarge wrote:
> Now I have found
> So should I attempt to set up a user group that is allowed access to
> the ntfs file system?

There are many ways to skin a cat. Which is the correct one for you, we can not say. Me, I use

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)