read raid ext4

When I tried 11.2, I did it with ext4 and software raid.
I submitted the following bug:

Now I was asked to provide the yast log.

I switched back to by 11.1 system, have the 11.2 still on the drive but don’t know how to read it.

I cannot mount it from 11.1 as I used ext4 for 11.2. What are the commands when I boot in rescue mode? mount -t ext4 doesn’t help due its raid status. It’s just about read-only access to copy the log file to usb.

Thanks, Fabian

there is no support of Ext4 in the 11.1 kernel at all. The only way to get it is to upgrade to a newer kernel and install the ext4 tools

You could boot with systemrescuecd (SystemRescueCd) mount the partition and pull it off that way.


Sorry, I was not clear. I tried with the rescue mode of the 11.2 M6 DVD and an appropriate Kubuntu LiveCD.

On my 11.1 system, I don’t want to upgrade my kernel just to read a log file.

I tried to add the old 11.2 partion to grub, but couldn’t figure out the proper configuration (kernel name, …). I even installed 11.2 M6 to VirtualBox to copy the grub command from there but that didn’t work.
This way it was easy to add 11.1 to the grub menu.lst of 11.2.

I guess I wasn’t clear, I did not mean you should try and use the rescue mode of opensuse or a livecd. SystemRescueCd is very useful rescue cd it includes a lot of useful tools and recent kernels (ext4 support).