read lvm external disc

hi I have an external disc that was a partition of an old system mounted with LVM.
So when I try to connect it via usb I obtain when I digit pvscan:

WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
/dev/sdb: open failed: No medium found

how can mount this disc??

Try (in a root shell):


vgscan --verbose
vgchange --verbose -a y
ls /dev/mapper

With a little luck, there will be a device in “/dev/mapper”, and the verbose output of the above commands might help you recognize it. Then you can mount using that device


fscd /dev/mapper/FOOBAR
mount /dev/mapper/FOOBAR  /mnt

Change the “FOOBAR” to whatever is the appropriate name.

Before you can unplug the external drive, you should unmount it and then use a “vgchange -a n” on the LVM name (if you know it). Or the easier way would be to shutdown your system and then unplug the external drive.

Understanding that with the vague term “external disk” you mean a disk that is spontanious connected to an USB connection of a running system (the fact that this disk may be inside or outside the metal case op the system is unimportant), I agree with nrickert.

Be aware of the fact that while there is lot done to handle the (un)mounting on behalf of the desktop user of such devices when they contain file systems on such mass storage devices or on partitions of them, there is nothing of the kind for file systems on logical volumes on the same.

Thus no automatic handling. You must use the appropriate LVM tools to manage this.

hi yes I have a 3.5 disk connected via USB.
I have some problems with that commands:

vgscan --verbose
WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
connect() failed on local socket: No such file or directory
Internal cluster locking initialisation failed.
WARNING: Falling back to local file-based locking.
Volume Groups with the clustered attribute will be inaccessible.
Wiping cache of LVM-capable devices
Wiping internal VG cache
Reading all physical volumes. This may take a while…
Finding all volume groups
/dev/sdc: open failed: No medium found
Finding volume group “vg_tar2”
Found volume group “vg_tar2” using metadata type lvm2

Is that what you wanted?

As far as I know, the rest of that output can be ignored. It is only there because of the “–verbose”. But if you don’t use “–verbose” the command may be completely silent.

Did you then use the “vgchange -a y” command? That’s what makes the lvm accessible.