reached target shutdown for 2minutes when shutdown

When no Btrfs then, make sure that, the Btrfs systemd services are at least disabled and, preferably, masked …

  • Except for the ones which are “static” …

Re-install with ext4, mark all btrfs/snapper/lvm rpms as taboo. Block all btrfs/snapper services. That solved the 2 minute hangs for me. I have two partitions (root and home) and make real backups. No need for btrfs and snapper glitches.

which of these?

**server3TW:/home/procuste #** systemctl status btrfs
btrfs-balance.service             btrfsmaintenance-refresh.path     btrfs-trim.service
btrfs-balance.timer               btrfsmaintenance-refresh.service  btrfs-trim.timer
btrfs-defrag.service              btrfs-scrub.service                
btrfs-defrag.timer                btrfs-scrub.timer                  
**server3TW:/home/procuste #** systemctl status btrfs


manythanks mrmazda

it seems that the greater doesn’t show me the shutdovn option, I did ctrl>backspace>backspace(twice) and chosen shutdown but didn’t help
minutes

both starting directly with iceWM and closed plasma and logged with iceWM didn’t help

opened plasma and ctrl>F3 and logged as user then startx then logout and did su and did shutdown -r now, didn’t help

did systemctl stop sshd then shutdown didn’t help

no differences, didn’t help

have you tried https://forums.opensuse.org/showthread.php/537027-reached-target-shutdown-for-2minutes-when-shutdown?p=2910415#post2910415 ? Set to 3 insted of 30?

yes thankyou, I set it to 3 but after two reboots nothing change

Hi and manythanks xorbe, It was already everything in ext4, / and /home separated partitions, I uninstalled all btrfs/snapper/lvm rpms, it provocates also the uninstall of gparted that I need, but for test I uninstalled, an tabooed them.
no btrfs/snapper services appears in >yast>>services manager so there was no need to block any service
but it didn’t solved, 2 minutes hang continues

As listed here on this ext4 system partition, XFS user partition, machine:


> systemctl list-unit-files | grep -i 'btrfs'
btrfsmaintenance-refresh.path                                    masked         
btrfs-balance.service                                            static         
btrfs-defrag.service                                             static         
btrfs-scrub.service                                              static         
btrfs-trim.service                                               static         
btrfsmaintenance-refresh.service                                 masked         
btrfs-balance.timer                                              masked         
btrfs-defrag.timer                                               masked         
btrfs-scrub.timer                                                masked         
btrfs-trim.timer                                                 masked         
 > 

manythanks dcurtisfra, It seems that after having uninstalled all btrfs/snapper/lvm rpms I have no btrfs service :

procuste@server3TW:~> systemctl list-unit-files | grep -i 'btrfs'
procuste@server3TW:~> 



maaanythanks ravas, I tried to follow the instructions of your link and the result is this:
https://susepaste.org/72721206

if the first numbers are time and starting from the last

Reached target Shutdown

I can see this that could maybe is the culprit:
from here

   36.115687] systemd[1]: shutdown.target: Job shutdown.target/start finished, result=done
   36.115689] systemd[1]: **Reached target Shutdown.**
   36.115708] systemd[1]: final.target changed dead -> active
   36.115709] systemd[1]: final.target: Job final.target/start finished, result=done
   36.115711] systemd[1]: Reached target Final Step.
   36.115854] systemd[1]: systemd-reboot.service: Passing 0 fds to service
   36.115859] systemd[1]: systemd-reboot.service: About to execute: /usr/bin/systemctl --force reboot
   36.115956] systemd[1]: systemd-reboot.service: Forked /usr/bin/systemctl as 2788
   36.116026] systemd[1]: systemd-reboot.service: Changed dead -> start
   36.116030] systemd[1]: Starting Reboot...

to here wher 36.11xxxxx became 126.14xxx

   36.150316] systemd-journald[435]: Received SIGTERM from PID 1 (systemd-shutdow).
   36.150323] systemd-journald[435]: systemd-journald stopped as pid 435
  126.149022] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
  126.154494] systemd-shutdown[1]: Sending SIGKILL to PID 437 (lvmetad).
  126.155632] systemd-shutdown[1]: Unmounting file systems.
  126.155809] systemd-shutdown[1]: Remounting '/' read-only with options 'data=ordered'.

hoping that this could be useful… ciao :slight_smile:

https://forums.opensuse.org/showthread.php/536145-OpenSuSE-Leap-15-1-shutdown-reboot-delay-of-90-seconds

Among many lines, the shutdown log showed these:

77.019608] systemd-journald[473]: systemd-journald stopped as pid 473
167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes…
167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).

As I do not need the LVM, I deleted the following packages:

liblvm2app2_2
liblvm2cmd2_02
lvm2

The service has vanished and shutdown is no longer delayed now.

~ Ed Vaessen

https://bugzilla.opensuse.org/show_bug.cgi?id=1129476

Or see the post after that…

Apparently setting the lvm2-monitor service to start “manually” and possibly stopping the lvm2-lvmtad and lvm2-lvmpolld services seems to be enough to solve the problem.

~ Bruno Pesavento

https://bugzilla.opensuse.org/show_bug.cgi?id=1129476

manythanks ravas, the problem on the laptop seems solved, the one on the desktop not.
I also answered on the thread you indicated me that resolved the problem on the laptop:
https://forums.opensuse.org/showthread.php/536145-OpenSuSE-Leap-15-1-shutdown-reboot-delay-of-90-seconds?p=2911998#post2911998

Removing the three lvm2 packages the problem seems solved on the laptop (a tuxedo infinity pro processor= Intel Core i7-8565U, RAM=32Gb, 2TB SSD disk) but not solved on the desktop computer, if it can be useful I attach the two shutdown log (obtained following the instructions here Debugging ) of the laptop where the problem seems solved:

the log before removing the three lvm2 packages and where the shutdown was slow
https://susepaste.org/72721206

the log after removed the three lvm2 packages and where the shutdown was fast
https://susepaste.org/68442920

and also I attach the log of the desktop where I removed the three lvm2 packages but the shutdown remain slow
https://susepaste.org/93130715

the interesting rows seems these

 322.929047] systemd-journald[502]: systemd-journald stopped as pid 502
  322.936530] systemd-coredump[2574]: Failed to connect to coredump service: Connection refused
  412.928467] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
  412.933397] systemd-shutdown[1]: Sending SIGKILL to PID 1716 (rsync).
  412.933931] systemd-shutdown[1]: Hardware watchdog 'iTCO_wdt', version 0
  412.934401] systemd-shutdown[1]: Unmounting file systems.
  412.934505] systemd-shutdown[1]: Remounting '/home' read-only with options 'data=ordered'.

I had too many tabs open, and posted in the other thread.
Check out https://bbs.archlinux.org/viewtopic.php?id=163768