Reached Target Graphical Inteface

Hi all,
the last few days I have this problem - when I reboot my system (13.1x64, XFCE) it gets’s stuck at:
Reached Target Graphical Interface
then I have to switch to terminal (Alt + F2), login as root, and do: init 5
then it goes to the graphical interface as it is supposed to go

I have seen some instances of the same problem, but it was always due to a nvidia card - I have intel integrated card (see at the end of the message) - although I tried some of the generic solutions nothing worked
any help is appreciated
DImitris

PS my graphic card:
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I encountered this problem when I tried to be clever and edit YaST>System services, inadvertently disabling a service that I needed. Have you changed any system services?

Before you issue ‘init 5’, maybe have a look at

systemctl status xdm.service

Is it running?

Maybe the following will yield a clue

journalctl -b

On 2014-03-02 16:56, darlac wrote:
>
> Hi all,
> the last few days I have this problem - when I reboot my system
> (13.1x64, XFCE) it gets’s stuck at:
> Reached Target Graphical Interface
> then I have to switch to terminal (Alt + F2), login as root, and do:
> init 5
> then it goes to the graphical interface as it is supposed to go

Known and reported bug with no solution yet (Bug 846832). Yes, do init
3, init 5 to retry. Or install and use gdm instead of lightdm.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Good find Carlos… and yes changing the display manager is worth a shot.

Hi all,
thanks for the responses -
I switched for a brief moment to KDE, and then - after switching back to XFCE I have the problem so I might have messes something in the process
here is the output from systemctl status xdm.service
xdm.service - LSB: X Display Manager
Loaded: loaded (/etc/init.d/xdm)
Active: active (running) since Sun 2014-03-02 10:36:27 EST; 7h ago
Process: 1047 ExecStop=/etc/init.d/xdm stop (code=exited, status=0/SUCCESS)
Process: 1137 ExecStart=/etc/init.d/xdm start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/xdm.service
├─1148 /usr/sbin/lightdm
└─1154 /usr/bin/X :0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Mar 02 10:36:26 linux.site systemd[1]: Starting LSB: X Display Manager…
Mar 02 10:36:27 linux.site systemd[1]: Started LSB: X Display Manager.
Mar 02 10:36:27 linux.site lightdm[1165]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Mar 02 10:36:38 linux.site lightdm[1214]: pam_unix(lightdm:session): session opened for user dimitris by dimitris(uid=0)

I will try gdm now, and see if that works

Dimitris

switched to gdm - and it worked
works for me for now
thanks

Good to know. :slight_smile: