Re: Yet another mysteriously stopped wireless

dxgreen wrote:

Is wpa_supplicant available? NM seemed to be having trouble starting it.

One thing - My system is 11.1, but it has trouble connecting wirelessly when the
wired interface is plugged in.

What things were upgraded?


Yes, I made sure it was installed. The behaviour is independent of whether the eth0 interface is active or not.

As to what was updated, I can’t remember as it was sometime last month during the scheduled weekly update.


Double checked and wpa_supplicant is installed, however it doesn’t seem to be running and I can’t get it to start.
How do I start it manually (and where are the autostart commands hidden) ?

I’ve also installed the wpa_gui but it simply reports that it can’t connect to wpa_supplicant.

Below is the output from iwconfig when working at my office. The cell identified is an unencrypted, public access WiFi node.

david@gslap01:~> /usr/sbin/iwconfig

lo no wireless extensions.
eth0 no wireless extensions.
wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:“Telstra CBD”
Mode:Managed Frequency:2.432 GHz Access Point: 00:11:21:7D:49:B0
Bit Rate=1 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality=56/100 Signal level=-70 dBm Noise level=-71 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

The wlan0 interface appears to be associating with the AP, but it still doesn’t show up in NetworkManager, and I can’t explicitly connect to it. When I try, all I get is an instant disconnection notice.

I would really appreciate some ideas because this is starting to affect my work.


I can only guess, but those updates must have corrupted something. Have you
tried using YaST to refresh all the pertinent packages? I would start with
NetworkManager, NetworkManager-xxx (xxx is kde, kde4, or gnome depending on your
desktop), and wpa_supplicant.

I looked back through the thread and didn’t see what you are using for a
desktop. If KDE4, I would load KDE3 and try it. There have been some reports
that the KNM applet doesn’t always work correctly.