Re: Failure of WPA2 Personal with openSUSE 11.1

On 2009-01-07, Larry Finger <> wrote:
> A number of people have reported difficulties in using WPA2 with
> openSUSE. I have no idea why it works, but the “fix” is to use YaST =>
> Software Management to reload the same kernel from the repos.
> Magically, WPA2 works with AES or TKIP+AES encryption.

Larry, it does not works for me.
It works only if I connect without protection.
Tried with wep, wpa-personal 1/2.
My wifi router has options : no-protection, wep, wpa-psk( 256 bit ),
wpa-aes ( 256 bit ). Tried with all but the only that works
is without protection.
Tried to reinstall kernel from dvd and again to reinstall
it from oss/repository ( )
OpenSuSE version is 11.1, with kernel :
Wifi card is : Atheros Communications Inc. AR242x 802.11abg Wireless PCI
Adapter (rev 01)

I can see correctly the wlan and wifi networks around.
iwconfig is :

wlan0 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point:
Bit Rate:12 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality=7/100 Signal level:-90 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

with iwevents I try to connect with NetworkManager and I just see
events :

Waiting for Wireless Events from interfaces…
16:58:18.514751 wlan0 Scan request completed
16:58:24.543143 wlan0 Scan request completed
16:58:30.546265 wlan0 Scan request completed
16:58:36.550232 wlan0 Scan request completed
16:58:42.560157 wlan0 Scan request completed
16:58:43.594287 wlan0 Scan request completed
16:58:51.197451 wlan0 Scan request completed
16:59:51.202382 wlan0 Scan request completed

Do you have any idea

Best Regards

I have not tested with any 32-bit kernels - only the 64-bit version.

I opened a Bugzilla on this question, but as a kernel reload from the
repo fixed it, mine was closed. You need to open one of your own.


I guess I have a similar problem.

I opened a thread with all due details here:
iwl3945 opensuse 11.1 - wireless down networkmanager idle - openSUSE Forums

crossing fingers


On 2009-01-10, Paololinux <> wrote:
> I guess I have a similar problem.
> I opened a thread with all due details here:
> ‘iwl3945 opensuse 11.1 - wireless down networkmanager idle - openSUSE
> Forums’ (
> crossing fingers

Paolo, it seems mine is solved.
I saw with ‘iwlist scan’ that my network has wpa1, even if I thought it was
2. Tried with 1 and it seems it works.