Re-enabling wireless n

I have installed OpenSuse 13.1 and I have slow wifi. Network Manager is saying that the connection speed is 1MBit/s and Band b/g. Normally I get 54MBit/s
I had the same trouble with 12.3 and fixed it by disabling the n band through this thread.
https://forums.opensuse.org/english/get-technical-help-here/wireless/484481-slow-wifi.html

For some reason after my install I don’t have the n band (according to the network manager). I didn’t upgrade when installing 13.1 but only formatted the root partition not home.
I have changed

etc/modprobe.d/50-iwlagn.conf

to

options iwlagn 11n_disable=0

rebooted but no change. I cant see any reason it would have kept the same same settings after I formatted.

I’m running OpenSuse 13.1
with KDE

02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 130 [8086:0896] (rev 34)
        Subsystem: Intel Corporation Centrino Wireless-N 130 BGN [8086:5005]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at f7200000 (64-bit, non-prefetchable) [size=8]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number dc-a9-71-ff-ff-0a-2e-90
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

In 12.3 when I disabled the n band it was by accident that I got it working, so I’m not having much success reversing what I did.[/size]

I tried my laptop on another wifi network and I was getting much faster speeds, although the WLAN Interface was still only showing b/g Band.
Back at home now I am getting a bit over half the speed On Opensuse 13.1 as what I do when I boot into Windows on the same laptop or my phone.
I guess it might be my router.

On 12/06/2013 05:26 AM, asarge wrote:
>
> I tried my laptop on another wifi network and I was getting much faster
> speeds, although the WLAN Interface was still only showing b/g Band.
> Back at home now I am getting a bit over half the speed On Opensuse 13.1
> as what I do when I boot into Windows on the same laptop or my phone.
> I guess it might be my router.

I know nothing if Intel wireless; however, the driver contains the following:

MODULE_PARM_DESC(11n_disable,
“disable 11n functionality, bitmap: 1: full, 2: agg TX, 4: agg RX”);

The “options iwlagn 11n_disable=0” line in /etc/modprobe.d/50-iwlagn.conf means
that 11n mode is fully enabled as nothing is disabled.

What is the difference in signal strength between your home network and the
other that you tried? Is there a significant difference in the amount of
interference?

How are you measuring speeds?

Just for kicks I did a fresh install. Nothing has changed.
I have been testing the speed with an on line speed test. Booting between window and OpenSuse on my laptop and using the same speed test. I also was using the speed test on my phone. I know speed tests can be a bit all over the place, but I had been getting quite consistent results for over a week. Windows and my phone were getting almost twice the download speed of OpenSuse.
I think the other wifi network that I tested on may have had a stronger signal.

Well tonight everything appears back to what I would call normal. It might be interference that has been causing the problems. There are other wifi networks the get turned on and off quite a bit. I’ll have to keep an eye on them.
Thanks