Re-enable oFono support in pulseaudio

Recently I’ve been trying to figure out why I can’t get bluetooth HFP (handsfree profile, to use with phones and such) to work on my system, despite having everything necessary installed (Pulseaudio, Bluez5, oFono). Eventually I found out that openSUSE’s pulseaudio package is intentionally disabling oFono headset support (look for --disable-bluez5-ofono-headset in pulseaudio.spec). This happened in revision 126 because there was no oFono package in the distribution.

However, now there is an ofono package in Tumbleweed (but not 13.2), so ofono support should be enabled again. I’m not sure who to contact to discuss this, so I’m posting here - should a bug report be filed, or should I branch the project in OBS and fix it myself, or something else? Or should it not be changed at all for some reason?

If you did an upgrade rather then a new install you may still be using old configs.

Well I did do an upgrade, but I’m pretty sure this is a compile-time flag. I also checked the assembly for the appropriate library and I can see that it’s skipping over all the calls to ofono. Basically I’m just wondering what the process is to get this build flag removed and make sure everything else still works.

You can of course compile yourself. and or post an error report on bugzilla

same user and password as here

For the record, it looks like someone pushed a fix for this to Factory’s pulseaudio package (revision 172), and it looks like everything works fine now. Thanks for the advice.