Re: Command Line.

Dear All,

I have just installed OpenSUSE 11.1 on my Desktop PC. When i boot up the screen lists three option as under -

  1. Open SUSE 11.1…
  2. Fail Safe open SUSE 11.1…
  3. Windows XP

Now, if i start with first option OPEN SUSE 11.1… it shows the screen with loads of drivers & kernal loading & finally its show as under -

**Welcome to OpenSuse 11.1 Kernel (ttyi)
linux-jblz login:
Last Login: Thu Feb 12 12:58:34 IST 2009 on ttyl
Have a lot of Fun…

Now the GUI (USER interface does’nt load & only it show the command prompt.

Kindly let me know what command should i use so the OS loading in graphical mode.

If i use the second option '*Fail Safe OPen Suse 11.1…*then i am able to load opensuse in GUI mode.

Kindly let me know how to do & i am completely newbie, this is the first time i am using LINUX.

Also i would like to know how to install printer, i have already download the drivers for my Printer.

Looking forward for reply.


What’s your display adapter?

You can try booting up in VESA mode by logging in as root (where it asks for your username / password) then typing:

init 3
sax2 -r -m 0=vesa
init 5

Thanks for your reply.

I tried, but the message showns as under -
sanghvi@linux-jblz:/> init3
Program ‘init’ is present in package ‘sysvinit’, which is installed on your system.
Absolute path to ‘init’ is '/sbin/init/, so itmight be intended to be run by user with superuser privileges (e.g. root)

-bash: init: command not Found.

I have used the same username & password which i had given at the time of installation.

Pl. also let me know how to install the printer.


Err, you need to do these commands as root and there’s a space between init and the number.

So, login as root - not your normal user.

It was typo error, actually while entering i had type as init 3

How do i login as root ? The USER & Password i entered is the same when i installed the OPENSUSE, so i thought the same user must be for root adminstrator.

Pl. let me know how do i enter as root user, i am completely new to linux.


If you followed (and used automatic configuration) the username is simply root and the password is the same as for your normal user account.

Remember, root can do everything and anything to a system, use it carefully.

Thanks a lot friend it worked.

Now how can i change the resolution of my screen can you guide me ?

Further, pl help me in installing my Samsumg All in one Laser Printer (SCX-4100), Linux was not able to find the drivers in the LIB, so i download the same from samsung site., but i am not able to installed the drivers.

Thanks a lot again,


Well, first of all we need to know what your display adapter is so we can get the proper drivers installed for them.

Someone else can give you a hand with the printer - that’s not really my forte :slight_smile:

Sorry, for asking how do i find which display adapter i am using ?


i found how to change the resolution.

Thanks for the help


You should have a button called “Hardware Information” in YAST - look the menus through for it.