Rdp not working, blank/black screen after new installation

Hi,

I have a new installation of tumbleweed, and can’t connect to my local Windows 11 VM hosted on another PC at my local network.

It used to works with other Linux installation I had on the same Pc now have OpenSuse instead and have no issue RDP from my Windows 10 laptop which I used for work.

Initially I tried Remmina with RDP plugin, I then tried using xfreerdp, still doesn’t work, all black screen.

The command I used is:

paul@linux:~> xfreerdp /v:QEMU-WIN /u:Me /p:MePass /cert:ignore /log-level:DEBUG > rdp.log

I think the error might be related to this, but have no idea what’s that means:

[13:55:05:037] [12026:12027] [WARN][com.freerdp.core.rdp] - pduType PDU_TYPE_DATA not properly parsed, 562 bytes remaining unhandled. Skipping.

Here is the debug log:
https://pastebin.com/tzPCCkTm

This really doesn’t answer your question, but we’ve always used Chrome Remote Desktop.

It’s sooooo easy and versatile - never had a problem.

Thanks, noted.

But that’s another service running on the server, and RDP is in-build or part of Windows AFAIK, suppose to be simple.

/rfx flag seems fixed it.

/rfx                              RemoteFX

Not necessary the best option, but hey it works for now.

1 Like