RC2 KDE 64bit Live & DVD fails to boot after installation

Installed RC2 KDE 64bit on my second partition and installation goes fine but it freezes soon when I try to boot that. Says “Call trace:” and some text (screenshots below). I’ve tried also RC1, both Live and DVD, btrfs and ext4, kernel safe options off/on, usb stick and burned to dvd but it always fails. I’ve 12.3 on my other partition (ext4) with updated kernel & xorg and it works flawlessly. Didn’t install grub since it’s already in partition where 12.3 is.

What else could I try?

Only error I spot in boot.log ( RC2 boot.log - Pastebin.com ) is “Error: Could not stat device /dev/sr - No such file or directory.”

http://bugzillafiles.novell.org/attachment.cgi?id=566061
http://bugzillafiles.novell.org/attachment.cgi?id=566060

My hardware:
CPU: Dual core Intel Pentium CPU E6300 (-MCP-)
Mobo: Intel D946GZIS version: AAD66165-302
Graphics: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4550]
Drives: SAMSUNG_HD502HI
Network: Card: Intel PRO/100 VE Network Connection
Audio: Intel NM10/ICH7 Family High Definition Audio Controller

Based on my recent full DVD install, I would reinstall over it using a KDE or GNOME LiveDVD as I feel there is something really wrong with the default openSUSE 13.1 RC2 DVD image install. In fact, I am going to give my suggestion a try and see if it works tonight.

Thank You,

Did you not put grub on the root partition ? I had thought that even if one does not want grub on the MBR (as the MBR points to a different openSUSE version with grub), then one still needs grub in the root partition.

I could be wrong, but that is typically what I do all the time and it works for me. I would not consider not putting grub somewhere.

I agree with that.

I seem to recall that Arch linux has an option to create “core.img” and “grub.cfg” without actually installing grub. I could not find that option on opensuse.

The alternative is to install grub somewhere (could be the root partition), but configure the boot install details to not set the active bit. Then the install does not mess with what is happening.

On looking at the screen dump linked from the OP, it looks as if he is trying to boot at the grub command line interface and getting it wrong. If grub2 is in use for 12.3, then regenerate “/boot/grub2/grub.cfg” (see the hints at the top of that file), and that should add a boot entry for the newly installed system.

I installed RC2 to sda1 and have my 12.3 with grub2 installed on root partition at sda2 which has boot flag. I run Yast’s bootloader which updated grub and added an entry for 13.1 which I selected when trying to boot that. Didn’t use command line interface. Is it really necessary to install grub to 2 different places? I’ve understood that the one where boot flag points is used and the rest are ignored. I installed 12.3 without grub when I already had other distro with grub installed on other partition and it worked without a problem.

For those who didn’t look the screenshot it says:
Please append a correct “root=” boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root gs on unknown-block(0,0)
CPU: 1 PID: 1 Comm: swapper/0 Not tainted 3.11.6-3-desktop #1
Hardware name (my mobo).

There are entries for RC2 and 12.3 on grub.cfg. Is there something wrong?grub.cfg: entries for 13.1 and 12.3 - Pastebin.com

I tried to user “os-prober” and “grub2-mkconfig -o /boot/grub2/grub.cfg” but it didn’t make a difference.

My partitions as lsblk shows them. For RC2 sda1 is mounted as /, swap+sda5 are same as below, sda2 isn’t mounted.

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOIN
sda      8:0    0 465,8G  0 disk 
├─sda1   8:1    0  23,3G  0 part      <-- RC2
├─sda2   8:2    0  23,3G  0 part /     <--- 12.3, boot flag, grub2
├─sda3   8:3    0   3,9G  0 part [SWAP]
├─sda4   8:4    0     1K  0 part 
└─sda5   8:5    0 415,3G  0 part /data
sr0     11:0    1  1024M  0 rom  

Seems the problem was with grub. I could boot to RC2 after I installed grub to it’s partition. I thought installing grub wasn’t necessary if there’s already one on other partition but doesn’t seem to be so. Maybe I should have installed grub in MBR at first place, shrug.

If you haven’t installed grub in some way or other, there will be errors when building the “initrd”. The script that build “initrd” expect to be able to update “grub.cfg” and perhaps more.

On 2013-11-04 23:46, oldcpu wrote:
>
> Cerule;2595604 Wrote:
>>
>> Didn’t install grub since it’s already in partition where 12.3 is.
>>
>
> Did you not put grub on the root partition ? I had thought that even if
> one does not want grub on the MBR (as the MBR points to a different
> openSUSE version with grub), then one still needs grub in the root
> partition.
>
> I could be wrong, but that is typically what I do all the time and it
> works for me. I would not consider not putting grub somewhere.

Same here.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-11-05 17:21, Cerule wrote:
>
> Seems the problem was with grub. I could boot to RC2 after I installed
> grub to it’s partition. I thought installing grub wasn’t necessary if
> there’s already one on other partition but doesn’t seem to be so. Maybe
> I should have installed grub in MBR at first place, shrug.

When I install a second openSUSE, I let it install grub on the root
partition, with “don’t boot from mbr”, so no set active flag, and do not
write default mbr set.

Yes, I can boot from the other (primary) grub, but the installer is
happier having its own grub. Less hassle, disk space is cheap. Why fight it?


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Glad to read its working now.

I think you had the correct idea. Use the 12.3 grub. But I have still needed to put grub on its own root partition for other openSUSE instances. There may be a way to avoid this (and not put grub on the root partition for other open SUSE instances) but I do not know how to do it.

I’ve done this multiple instances with grub on ‘root’ partition many times in the past, and there are users who have this as a pet peeve and have posted multiple times on this subject (disliking some default openSUSE settings).

There is a neat application called ‘updategrub’ which inside has the script ‘findgrub’ which gives one a very good map as to where grub is located on one’s PC. software.opensuse.org : updategrub I’ve never used ‘updategrub’, but I have run ‘findgrub’ on many PC’s and very much like the information it provides.