RC2 doesn't boot past udev (same as RC1)

OpenSuSE 12.1 RC2 does not boot: it does not get past the point where it’s loading udev. It has the same issue that 12.1 RC1 did.

This laptop is a brand new Dell Inspiron 14z. FWIW, Slackware 13.37 boots and installs just fine. Stats are here: Slackware64 on Dell Inspiron 14z

If anyone can help me out here, and/or fix RC2, it would be much appreciated, as I like OpenSuSE a lot

Try adding maxcpus=1 to the boot options at startup

M

Will it utilize more cores/CPUs then?

The “maxcpus=1” would directly affect the boot from DVD for installing. That option is possibly also added to the grub menu for future booting. But you can edit that later.

Note that I had a similar problem (stops at udev) on booting the DVD. I think it was the 64 bit DVD, but I’m not sure on that… It worked on the third try. I am not having that problem with the installed system. I suspect that the problem is only with the particular setup used on the DVD.

I do believe that the key point here is “Brand New”. The statement that … Slackware boots and installs … is that your experience or someone else’s?? It was noticed in the Slackware Report that was submitted that not all items are working. Could be that SuSE is not as lenient on the missing drivers as Slackware. I really don’t see the maxcpus doing anything -unless you are using an SMP kernel. By the way, are you using a LiveCD or was the openSuSE installed on the Laptop??
Take care,
Chuck

What you just said makes absolutely no sense. It’s not a report. Yes, Slackware64 13.37 installs and works almost entirely. Yes, that was written by me. As for “missing drivers”, what the heck are you talking about? USB 3.0 xhci_hcd gets loaded, just that kernel 2.6.37.6 may be why. Yes, “brand new” laptop may have something to do with it. I am using the OpenSuSE installer DVD, not a live CD. The USB 3.0 is more tied (i believe) to age of kernel and being brand new, but I’m not worried about USB 3.0 working here. This isn’t just “USB 3.0 don’t work but USB 2.0 port works” like with Slackware: this is “Installer DVD will not even get past boot so that I can install it.”

My point is not to compare Slackware to OpenSuSE but to point out that a different linux distribution works on this laptop, hence it’s no the laptop. And much less I could say here “well Slackware configures udev properly, why can’t you?” but I’m not using that logic so much as pointing out that now is the wrong time to try and use that logic as you did in your post. While I appreciate your attempt to help, please refrain from replying again. I’ll try the other guy’s maxcpus thing and get back with you.

(By the way 11.4 opensuse is installed on my netbook and so far works fine, but that’s the fun of asus eee pc :slight_smile: )

I’ve reported the same issue with a Travelmate and udev. See here: has anyone installed rc2 from the dvd yet? - Page 3. When you follow the Link in the mentioned post you can find also that the installation of other systems just works.

No helpful hint or comment so far. For me it is a 12.1RC bug.

Steve.

This may be of interest

https://bugzilla.novell.com/show_bug.cgi?id=722858

M

Yes, that is interesting. Thanks.

I said that I installed from the DVD. But I actually installed from a bootable USB created using the DVD image. It’s a bit hard to unplug all USB drives when installing that way :frowning:

I installed Beta1 and rc1 from the live KDE, also written to a USB. I did not have comparable problems there. So I think this is specific to the way the DVD has been configured for its own booting.

Thanks! Worked like a charm! The installer still seems a bit slow (despite running an i3 ) but otherwise so far it worked and i am now using RC2 on my dell! :slight_smile:

Thanks M. Interesting, indeed. Looks like that I ran into the timeout mentioned in comment #38. There is already a udev fix for it which hopefully solves the installation problem for me.

Steve.

On Fri, 11 Nov 2011 19:56:03 GMT
interele <interele@no-mx.forums.opensuse.org> wrote:

> This may be of interest
>
> https://bugzilla.novell.com/show_bug.cgi?id=722858

I got stuck at udev whilst installing RC2. However, I did not have a USB
thumb inserted. May have been the timing problem but I didn’t wait 10
minutes to find out. I merely hit reset and install went through OK -
apart from the usual mid-install freeze at 1st reboot.


Graham Davis, Bracknell, Berks.
openSUSE 11.4 (64-bit); KDE 4.7.3; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nVidia driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

Harshness was not intended nor expected in return. I apologize for any offense taken -but- that I did not really send. That is the problem with textual conversations -especially if the two parties are not familiar with each other. I was perhaps to short in mine -but- nothing was meant to cause any hard feelings… nor to insinuate anything bad about you. It was a report, to me … made by you as it turns out … but it was a report. A war was not meant to be started just asking questions to get more verification on the problem. I still do not see how the number of CPUs fixes the problem -but- that is something to learn. Thanks for asking and thanks to interele for the info about the maxcpus. I’ll keep that one in mind.

OK so you can marked this fixed in 12.1 stable release :slight_smile:

WHAT??? It still fails in 12.3 final.

My HP Compac nc6400 failed to install 12.2 and now fails to install 12.3 at udev. I have it set to single core, and all attachable devices turned off and nothing plugged into the computer.
It works well with 12.1 (when I re-enable things in the BIOS).
12.2 final will the installation procedure, but has another problem later. It does give me a quick flash of an error message just before it goes to graphics mode. Those error messages need to be visible until they can be read, even after switching out of text mode. Otherwise they get missed (who watches the screen constantly?)
12.3 stays at Starting udev until the system powers down due to over temperature CPU.

If the problem was know for 12.2 RC1, how did it get to 12.3 final?

12.3 works fine with my desktop system (with an AMD 3 core).

In all honesty, we do not know that it is the same problem. It might be the same symptom, but a different problem.

You should start a new thread.