RC1 KDM Autologin is intermittent

Hello,

Initially, autologin worked. Then out of nowhere it stopped working and I was taken directly to the login screen. I was able to login fine. I’ve checked “Login Manager > Convenience > Enable Autologin” and the box is checked. Not really sure where to look next. Any thoughts or suggestions? Is this a bug?

I am not sure this is a bug or not, but will advise, don’t use auto login for security purpose.

I appreciate the advise, however this is installed on a home laptop. It’s primarily used by my kids to play games(they like the games for linux best), so I’m trying to make it as easy as possible for them. Any other suggestions?

I have my system set to auto logon and have had any problems. I did a fresh install of the RC.

I believe you…It doesn’t happen consistently. It worked fine this morning…and stopped working once this afternoon…and its working fine again. very strange behavior. I can’t imagine that its anything that I’m doing…perhaps it will go away with final.

Sorry, I cannot help you here regarding autologin, but maybe you can make things easier for your kids by allowing passwordless login for their user. In case of failed autologin, all they need to do is to click login.

Cheers!

I had the same problem with autologin intermittently locking up in 11.2.
After some research, I used the YAST -> /etc/sysconfig Editor to check the setting of desktop -> Display manager -> DISPLAYMANAGER. To my suprise, I found two DISPLAYMANAGER varaibles, one set to gdm and the other blank. When I set both to gdm, autologin started working again. My guess is that when I added KDE, the installer added a second DISPLAYMANAGER variable without checking to see if one already existed. Unfortunately, DISPLAYMANAGER isn’t the only variable that was duplicated, but those aren’t causing me problems that I know of yet.

Incidentally, I also disabled autologin from YAST and instead added these lines to /etc/gmd/custom.gdm
[daemon]
TimedLoginEnable=true
TimedLogin=<your username>
TimedLoginDelay=10

using the timed login instead of autologin gives me a chance to hit [ESC] and change the user or desktop if I want on boot