RC 1 -- Selecting Locale causes it to crash every time

Has any one clicked on “Locale” in System Settings?

It is always crashing :slight_smile:


Executable: systemsettings PID: 3571 Signal: Segmentation fault (11)

Remember to have fun!


Yes it did this every time clicking on Locale when just running the RC1 KDE LiveCD. :frowning:

I’ll check Bugzilla to see if anything has been submitted.

This might be related to having a bad language set e.g. “en” instead of “en_GB” or “en_US”

grep locale ~/.kde4/share/config/*


I should have quoted this from https://bugs.kde.org/show_bug.cgi?id=262488

------- Comment #17 From John Layt 2011-02-07 20:21:56 (-) [reply] -------
For all new bug reports, please state the following:

  1. Distro and version
  2. If this is with a fresh install of the distro (state medium, live CD or
    install DVD?), or upgrading an old install (state original install version and
    media if possible)
  3. What language you set the system language to in the distro installer
  4. the contents of ~/.kde4/share/config/kdeglobals (or just .kde) [Locale]

To work around the problem:

  1. Edit ~/.kde4/share/config/kdeglobals (or just .kde) and remove the Language=
  2. Run the module and set your languages correctly

Basically I can patch to stop the crash in 4.6.1, but I also need info to track
down where the rouge language codes are coming fro

Had this bug in 4.6 RC2 as well and yes changing the locale from ‘en’ to ‘en_US’ fixed it for me

The odd thing is, this invalid setting used to be caught, and a simple message about “invalid language” was displayed. Then sometime around M5 it changed and started causing the Locale program to crash. Obviously, fixing the program would be the ideal solution. But changing the invalid default language code would at least make it “go away” in most (pretty much all) cases.

Thanks eng-int. That worked. Removing the "Language= " line allowed the user to enter and modify Locale.

Formerly known as Localization.