Razer Deathadder Install

Hey, I want to Install my Razer Deathadder on Suse 11.1, I allready found a programm: bu3sch.de
The problem is, I cant compile the code. I cd into the folder with the source and use make (as root) and get this error:

xxx@linux-nzsg:~/Desktop> su -
linux-nzsg:~ # cd /home/xxx/Desktop/deathaddercfg-004
linux-nzsg:/home/xxx/Desktop/deathaddercfg-004 # make
cc -std=c99 -O2 -fomit-frame-pointer -Wall -D_BSD_SOURCE -D_GNU_SOURCE -DVERSION_=004   -c -o main.o main.c
make: cc: Command not found
make: *** [main.o] Error 127
linux-nzsg:/home/xxx/Desktop/deathaddercfg-004 # 

Can someone plz help me to install?

install, make,gcc/gcc++, kernel sources & kernell headers & you should be good to go


I installed gcc/gcc++ and kernel sources through yast, but where can I find my matching Kernel Headers?
Another question: do I have to install something to use make?

My bad, kernel headers should now be provided along with kernel sources.There is a program called make, which,when some,not all, programs make calls to when installing.It can be found via YaST- software management


I got different make packets e.g. makedev, cmake, checkinstall…
Which is the one I need?

Ok make works now and I allready compiled 3 other programms but I get this Error trying to compile deathaddercfg:
nopaste.info - click to see my errorlog

Baah I get crazy, now I get this error:

CMake Error at CMakeLists.txt:8 (message):
  Could not find library "libusb".  On Debian Linux try "apt-get install
  libusb-dev" to install the library.
Call Stack (most recent call first):
  CMakeLists.txt:14 (check_lib)

-- Configuring incomplete, errors occurred!

P.S. I installed libusb, but I dont find the files…

can you post a link to the program you are trying to compile ? I personally haven’t used it,but, if i can see the program/software, i may be able to get a better idea,or maybe someone who has used it will step in


Thx I want to use this:

Something new?

Nothing yet, still trying to see what i need to do. Maybe you could e-mail the author/packager ?


So you got problems too?
P.S. E-Mail sent

How did this go. I am having exactly the same issue.

Yeah. I have same problem with this soft for my Deathadder.
It would be kind to explain such linux noob as me how to make it working with DETAILS. :slight_smile:

Hi all.

just been having the same issue - deathadder arrived in post this morning and I seriously need to configure it.

Anyway - I had the same “libusb” not found when running cmake .

CMakeError.log said:
“/home/hugo/bin/razercfg-0.06/CMakeFiles/CMakeTmp/CheckIncludeFile.c:1:17: error: usb.h: No such file or directory”

So - to fix - do

locate usb.h

(you should get lots of files listed… Choose the one that matches your system)…

For me, I found the file


Then edit CMakeLists.txt and on line 23 replace

check_lib(usb usb.h)


check_lib(usb /path/to/my/usb.h)

where the “/path/to/my/usb.h” is the full path to usb.h you discovered earlier.
e.g in my case I used

check_lib(usb /usr/src/linux-

Save CMakeLists.txt and run

cmake .

again. Should work after that.

I may be premature in posting this as I’ve not finished off the rest of the install procedure yet - but fingers crossed.

Ok, that all worked…

Note: I followed the instructions in the README but after a reboot you’ll need to go to YAST → System Services (Runlevel) start the razerd daemon… Once that’s done then you can happily use the razer config tool, qrazercfg.

So now my mouse pointer isn’t moving at 18,000 miles an hour. On my deathadder 3500 the software doesn’t affect the LED’s though - but that’s not an issue now that the mouse is usable again.

Oh yeah - I also had to set KDE mouse acceleration to 0.1x because the **** mouse was still to fast at it’s lowest DPI setting of 450…

All the best,