RasPi cant connect to google

While running a fully patched Leap 42.3 on a RasPi I tried to connect to google using Firefox (actually still version 50):

 The website tried to negotiate an inadequate level of security.


 www.google.com uses security technology that is outdated and vulnerable to attack. An attacker could easily reveal information which you thought to be safe. The website administrator will need to fix the server first before you can visit the site.



I did not see that on an Intel Leap.
Does anyone know how to override this?
AND…is there no newer FF available for ARM-Leap?


Unfortunately, simple and multiple reloads don’t fix it.
Selecting the right cipher suite seems to be somewhat out of my hands…

Have you run a “zypper dup” to see if there is a more recent TW image available?
If that doesn’t work, then

Recommend you submit a bug to https://bugzilla.opensuse.org.
Sounds to me it’s likely an upstream problem, not something you’d likely be able to fix.

It’s my feeling that despite the error suggesting the problem is server-side, that’s probably not true… Websites, particularly well-visited websites like Google.com should be configured and maintained with “adequate security”

As you noted, FF v50 is considered obsolete and should be updated.


Yes, system is up to date. Bug created: https://bugzilla.opensuse.org/show_bug.cgi?id=1067780