RANT RANT RANT: I just have to get these off my chest....

Things that REALLY p**s me off with openSUSE 11:

  1. PRTSCR does not work! I re-assign it, it works, and it’s forgotten on reboot.
  2. Volume control keys are always forgotten on reboot.
  3. Having to login to the forums on each visit, lately every 2 minutes! It’s a little thing called a “cookie” if that helps.
  4. Reporting a bug and being told to “get used to it, that’s how it is now”.
  5. The “save password” checkbox that is a complete waste of time, because it NEVER does!
  6. Enabling “nopasswords” in visudo doesn’t work, I still need a password to run Yast2 (yes I am a member of “wheel”, and I don’t give a fried rat’s a-hole about the security implications thankyou, so please don’t mention it).
  7. Cursor keys keep mysteriously stopping working under konsole.

…well, no number 7, actually apart from those few things openSUSE is still great :D.

Sorry, but I just had to get that lot out, I feel much better now :).

Soapbox IS THE forum area to do this sort of rant. :smiley: I’ve been known to do my own rant on occasion. :smiley:

Having read (and sympathize with) your rant, … are not items 1,2, and 6 in essence the same problem?

I note you have two different item-3s!

Item-3 (first instance) about constantly having to log in is not a fault with openSUSE. The forum has a major problem here (over the weekend of 28/29 June). If not fixed now, it should be fixed very soon. So its kind of unfair to critisize openSUSE-11.0 for a forum fault (although this weekend bug definitely is worth a separate rant. :rolleyes: ).

Item-3 (2nd instance) about being told to accept a bug and “get used to it, that’s how it is now”. Can you provide an example ? … having typed that, I don’t know of one distribution that can fix an OS bug the next day. I think this is more systemic to the software world, than an openSUSE fault.

I too have my pet peeves of things that are not fixed yet, but ARE being worked on (for example: reliable hotplug automounting with read/write of external NTFS hard drives is still buggy).

But I do know we get pretty rapid response in some other cases. On sunday morning I read of a problem with the Packman packaged version of “kdenlive”. I confirmed this problem myself, noted the problem first occured with an update to a dependency application a month earlier, and sent the Packman packager a polite request for help (with a succinct, but complete, summary of my investigations). By early afternoon on Sunday, the Packman packager had a fix out, which was very quickly available on all the Packman mirrors for downloading. Now that was FAST!! … so its not all doom and gloom when there are bugs. Some are fixed pretty quick.

Don’t know, don’t use.

Works here.

It was a problem with the Novell login servers - the cookie was dated up to 2009 June - you would know if you bothered to look at it.

If you don’t like it - do a better version yourself. You don’t need to use it, there are alternatives.

No issues but then again saving things like root password is stupid idea in the first place.

You’re using the wrong operating system. http://www.microsoft.com/windows

Works fine.

You fail.

WTF. Unecessary much?

@wehrmacht: The “not remembering root password thing” annoys me to. (Not because I want it, but because it’s always ticked and does NOTHING.)

If you whine, don’t expect that people will deal with you with silk gloves.

The volume keys on my laptop do change the volume. It is still not perfect like under

In my case I need to keep the volume on the Task Manager up to the highest setting I may ever want it.

then I can use my volume keys to lower or raise the volume up to that level. It won’t slide the volume setting on the KMix taskmanager, but it still raises and lowers the actual volume.

so it isn’t completely broken

if your talking about packagekit remembering the password, it works fine here…

Rather than start a similar thread of my own, I’ll post my complaints in this one:

  1. Pulseaudio. Somebody needs to take this piece of crap out back behind the barn and shoot it. I could ONLY get Amarok and virtualbox to work, and that was AFTER applying a workaround to avoid the connection refused errors. Everything (except frozenbubble) works after removing it and making it taboo.

  2. Packagekit: I prefered the 10.3 way where the updater icon remained in the systray in GNOME.

  3. perl-qt has been removed. I just spent the past 2 weeks at porting my fairly substantial perl-tk application to perl-qt. If I can’t get this back or make it work myself, I won’t be able to update my work machine.

Other than that, the improvements to zypper make the upgrade worth it.

After 10 seconds of looking at web pin, I get this:
results of openSUSE-11.0 webpin search for perl-qt :eek:

Instead of ranting, you can better talk objectively about any problem and thinking about possible solutions. Then you will be surely get helped. :slight_smile:

But this is the soapbox-- it’s the place to rant!

I’m certain he didn’t actually expect help…

wehrmacht wrote:

> 1. PRTSCR does not work! I re-assign it, it works, and it’s forgotten
> on reboot.

Why re-assign it? I have an 11.0 system installed clean and PRTSCR works
fine - just hit the button and ksnapshot screen pops up.

Graham Davis


I came in to punch the wall and scream!

It helps sometimes :).

But I just installed and switched to KDE3, and all my problems are now solved.

Even my laptop (volume) keys are working as normal again :).

I’m shocked at how fast and responsive 3 is compared to 4.

Using KDE4 is like living in one of those dreams where you are trying to run away from the monster and you can hardly move.

Like you’re trying to run through a vat of honey!

Begone horrid KDE4 monster, läss mich in ruhe!!

You could say the same thing about pulseaudio.

Don’t think I’ll do near KDE4 this release. I’ll wait for 4.1 in Opensuse 11.1 :slight_smile:

KDE3 in Opensuse 11.0 is excellent. Very fast, stable and a dream to use. Yast is so much faster it’s great. I now have about 11 repositories and it starts in no time at all… Compared to 6 in 10.3 and had to wait ages!

Can we start a thread about the things we love in Opensuse 11? :smiley:

Funny you should raise that point, I haven’t had any issues with pulse yet!

Very odd ö_Ö.

…oh wait, now I remember, it was the first thing I removed on first boot :D.