Random X Crashes

I am having a weird issue whereby the KDE (4.4.3) desktop suddenly crashes and goes back to the KDE prompt - screen just goes black and then I can log in again, till same happens. I can’t confirm this behavior on earlier versions (prior to 4.4.2) of KDE since I did a text install a while ago on the new computer so first KDE there was 4.4.2, same behavior.

The computer in question is a Core i3 with internal video one, Q57 ASUS-made chipset, and the latest kernel from the HEAD repository. I was able to downgrade to kernel 2.6.33 (the earliest that supports my video hardware), but the issue is persistent. It does not seem to be linked to a particular program, though it happens during (any) program start-up. I’ve had it with Firefox, OpenOffice, Kontact, Konqueror.

I am not quite competent about log files, but the only file I found to contain some possibly meaningful info was /var/log/messages. It contains a line about something can’t find the process id, which seems to coincide with the time of the crash. I can’t quite recall the exact message, but my googling and searching through this forums didn’t help.

I also tried the KDE Live CD with Milestone 7, and it happened there too. Only the above mentioned log file did not contain that information.

If you could direct me to what other log files might be helpful, or what might be the cause of the issue so I can try fixing it, that would be great. Otherwise I am stuck with Win 7…

I know it is a new machine, but many strange program abort problems can be caused by bad or poorly seated memory chips. To eliminate this possibility, I suggest you run the Memory Test, which is on the Suse installation CD (and maybe DVD). Do 4 passes of 8 tests to see if any errors (shown in red) occur.

Linux generally tries to use all the available memory for programs and file buffers (if any left over). Windows is more frugal so it may survive bad memory better than Linux.

Hope that helps but it may not.

Thank you for your suggestion. Oddly enough, my dvd drive died this morning, so I can’t run the memory test :frowning:

I will surely do that as soon as I get a replacement. Windows has no issues at all, and I also encounter no issues within Virtual Box.

Well, I fixed the DVD drive and ran a memory test. All ok, so it is probably not the memory.

I am beginning to suspect xorg (and/or Intel driver). In order to have X run on my machine, I had to upgrade the kernel, and xorg (X11 repository) for the new Intel driver. I assume the same version of xorg is used by Milestone 7, which is why I get the same kind of behavior there.

I also tried to create a new user, and things are the same. Running as root also got me the same X crashes upon application start.

As a further proof of my suspicion of xorg/intel driver, I did not experience that behavior when running OpenSuse as a guest OS within Virtualbox where the video driver is not the intel one.

Any clues?

It is a bit strange. A bit more information if you would. I was reading the previous posts of yours under:

Intel HD graphics with opensuse is there a way?

and you seem to be using much the same hardware now. Did you have the graphics working under 26.6.33-30 kernel for a couple of months and then, all of a sudden, for no apparent reason, it started crash? If so, that was why I was wary of focusing on the Intel driver. So what change might you have made to the software side if any? Was there a kernel upgrade after 2.6.33-30 or upgrades to xorg or mesa? Please think of all changes / upgrades made and detail them here for the gurus to examine.

From what other posters have said, support for Intel graphics still seems problematic. You have tried the obvious of using the 11.3 CD so upgrading to that would not appear to be an option. That also rules out HDD problems such as bad blocks causing crashes.

Sorry I am baffled.

Thank you for your reply. In fact, I wish I could confirm any of your suspicions. The hardware is the same, with nothing on it changed since I bought it.

Also, I haven’t used OpenSuse that much over the past few months - mainly due to that problem. I had to add the HEAD repository to get a newer kernel, and also the X11 repository to get newer X/Mesa/Intel driver. Then I’ve done updates occasionally, but really don’t remember if that happened after such a casual update or was there all along. However, I remember I suspected a 2.6.34 (rc something version) from the HEAD repository to be the cause of the problem, so I downgraded back to 2.6.33 from the build service, without any improvement.

All of this leads me to believe it might be X-related or the intel driver in particular. I will try tonight to post relevant lines from a couple of log files, perhaps they’ll bring some light into the issue. Also, there might be other log files, which I am not aware of, that could contain relevant information.

What really puzzles me is that this only happens during (any) application start up, once the desktop is up and running. It would not happen if I just leave the system idle.

IIRC correct this is X-related. The packages from the X11 repo are experimental. I’ve had deep trouble, restoring the original Xorg packages did not completely fix it, some libXi link remained (don’t remember exactly). Again IIRC oldcpu suggests to install only some packages from that repo. You could search the forums for his posts on this.

I found another thread discussing the very same issue here.

Still no resolution though.