Random wireless disconnects

Hello everybody,
I have a hp dv3 2110eg laptop with OpenSuse 11.1 (KDE 3.5.10) and Windows 7 dual boot. My wireless disconnects and connects automatically at random intervals. I do not observe this behaviour when operating my laptop under Windows 7. Following some suggestions given in this forum , I uninstalled networkmanager and installed wicd. However, this does not seem to solve the problem. Given below are the relevant information.
uname -r


2.6.27.48-0.2-pae

/sbin/lspci

03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Net                                                                    work Connection


/sbin/lspci -n

03:00.0 0280: 8086:4237


/sbin/lspci -nnk


03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

dmesg

iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
iwlagn: Copyright(c) 2003-2008 Intel Corporation
iwlagn 0000:03:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
iwlagn 0000:03:00.0: setting latency timer to 64
iwlagn: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
iwlagn: Tunable channels: 13 802.11bg, 24 802.11a channels
phy0: Selected rate control algorithm 'iwl-agn-rs'
**firmware: requesting iwlwifi-5000-1.ucode**

The dmesg output shows firmware request (highlighted with red font), but i have already installed the firmware using YAST.
iwconfig


wlan0     IEEE 802.11abgn  ESSID:"WLAN-001F3F79C289"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1F:3F:79:C2:89
          Bit Rate=18 Mb/s   Tx-Power=15 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:  [3]   Security mode:open
          Power Management:off
          Link Quality=100/100  Signal level:-40 dBm  Noise level=-84 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

iwlist scan


wlan0     Scan completed :
          Cell 01 - Address: 00:1F:3F:79:C2:89
                    ESSID:"WLAN-001F3F79C289"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=100/100  Signal level:-43 dBm  Noise level=-85 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1A4E101BFFFF000000000000000000000000000000000000000000
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=000000000915c982
                    Extra: Last beacon: 84ms ago


Hope i have given all the information needed to troubleshoot this problem. Please help !!

Is there a specific reason you’re running 11.1? I would imagine the drivers have improved drastically with two releases. Troubleshooting wireless that’s not working at all is fairly straightforward. Troubleshooting intermittent wireless is very difficult.
How is your signal level?

>Is there a specific reason you’re running 11.1?
I would like to stick to KDE 3.5 for as long as possible ( Nov 2010 when the support for 11.1 is officially over).
I searched for a possible solution in other forums and came across this site https://bugs.launchpad.net/ubuntu/+bug/575492. Following the workaround, I created options.conf in /etc/modprobe.d and added the following

options iwlagn 11n_disable=1 11n_disable50=1

There was no drop in wireless connection for the past two days and if I delete options.conf, the problem reoccurs. According to the site, this bug affects Intel Corporation PRO/Wireless 5100 AGN cards. Since I’m not currently accessing any N-based networks, I can live with this workaround for the moment.