Random Proxy Warning Message

Since RC2 we have been getting a random Proxy Warning Message. We can see no reason for it and it is just with version 12.1. It does not appear on 11.4. Is this something new or is it finally a Linux Virus???

Authentication is required to set the network
proxy used for downloading packages.

          An application is attempting to perform an action that requires
          privileges. Authentication is required to perform this action.

It then asks for the root password.

This will pop up at boot time and randomly as we are logged on. It offers a choice of OK or Cancel. Naturally we have been picking the later. Anyone have any info on this??? Oh… and No, we are not trying to download anything when this just pops up. It just randomly pops up.


It’s more likely to be a KDE 4.7 bug. I have this on both my mashines (11.4 KDE 4.7 and 12.1 KDE 4.7.3) since the upgrade to 4.7. I think it is related to apper/packagekit or yast. It does not occur randomly on 12.1 since I disabled apper, but does occur when I update applications via yast.

OK. Thanks. I was gona leave apper out when we installed the latest release -but- we decided to test it. We’ll check out the KDE pages and see if anyone over there is complaining. Thanks for letting us know that we are not alone.

Take care,

I had these annoying messages too.
Just put:


in /etc/polkit-default-privs.local

**#> /sbin/set_polkit_default_privs**

And problem is gone.
Also, look over this topic: http://forums.opensuse.org/english/get-technical-help-here/applications/468131-why-authentication-required-set-network-proxy.html

No file !

-bash: /sbin/set_polkit_default_privs: No such file or directory

Are you actually using openSUSE?
It should be there then, otherwise your system is badly broken:

wolfi@linux-lf90:~/Desktop> rpm -ql polkit-default-privs 

And the package polkit-default-privs is required by the base pattern.

Time Machine!
Resurrecting a 2011 thread (aside from the reference to openSUSE 12.1)


Yeah, right.
And the underlying problem has been fixed over three years ago (Dec. 2011)…
So no need to change the polkit rules any more to get rid of this error message… :wink: