Random problem with opensuse 12.1 for a Sun Java Workstation: mouse and keyboard dont work at login

Dear All,

I am trying to run opensuse 12.1 in a Sun Java Workstation W2001z, with 2 AMD Opteron 264 processors.
When I was trying to install, I got the first problem. I started using the boot DVD and selected installation. At the moment I reached the first page of the installation process, where you have to check the license agreement, the mouse and keyboard are lost and I have to manually shutdown the computer using the reset button. Mouse and keyboard are USB devices, there are no PS2 ports. I tried several times until I selected Safe Mode using the F5 key for the installation. Then I could use the mouse and keyboard to proceed with the installation.
The installation was completed and I could login without any issues.
However, after shutdown and restarting, I reach the login screen, and the mouse and keyboard sometimes work, and I can continue, but most of the times they stop working and I cannot do anything but shutdown manually. Bad thing is that this happens even in failsafe mode. So its like a lottery, sometimes I will be able to use the mouse and keyboard, and sometimes not.
I have read some of the posts about mouse and keyboard freeze, but none of them have helped me.
I checked that USB legacy in BIOS is enabled, and still do not get it to work.
Does anyone have any suggestions?
Thanks in advance


Strange hardware produces strange problems :slight_smile:

pure guess since this is hit or miss I suspect a possible sync problem with the new systemd stuff. Try booting using systemV. I think you press F5 at boot screen then select.

Thanks for the advice… however, it didn’t work…
I played around and I found that if I start with the following boot settings I can avoid the problem:

showopts noresume nosmp highres=off nomodeset x11failsafe

So now it seems to work… however, as you say, strange hardware produces strange problems… I have found that I am supposed to have two processors, however, only one processor is recognized… any clue about this?

Thank you very much for your help.

On 2012-03-23 15:16, gtmartine wrote:

> So now it seems to work… however, as you say, strange hardware
> produces strange problems… I have found that I am supposed to have two
> processors, however, only one processor is recognized… any clue about
> this?

Failsafe booting has that effect. nosmp.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

and it seems that is the problem… if I boot without the option nosmp, then I loose the mouse and keyboard at login… if I boot with it, then I loose the 2 processors (with 6 cores each)…
It seems that this machine worked under opensuse 9.1 previously. Does anyone know where I can get the ISO for this version? I will try to downgrade to that version. I have been surfing the web to get the installation files, but it seems to be too old, since I cannot find a working link to get.
Or if anyone knows the how to fix the issue with the processors vs mouse/keyboard in version 12.1, I will be very thankful.
Thank you for your help,


I strongly suspect that you have a problem not with openSUSE specifically, but the kernel (2.6)

For example a Google search using relevant keywords reveals reported bug(s)

Judging from that, before you commit to using this machine however powerful it might be, you might want to research Linux kernel compatibility issues.


Note that Suse 9.1 is long long out of date. There is NO support for it ie no fixes for bugs and security issues.

Hi, thank you very much for your comments. Its been a while since I didn’t answer, since I have been looking for more information about this issue. Quite limited although.
It seems that TS has shown me the more likely issue: the kernel version.

Now my question is: Can I use kernel in Opensuse 12.1??? If yes, how can I get it and make it run?
So far I have searched for it, but not being able to find it. Also, the kernels that I have found (similar versions, but not the one that is supposed to work) need to be compiled and I have not been able to achieve this.
Is the quest of downgrading the kernel as painful as it looks?
Thank for your help,


You would need to compile it from the source on kernels.org but I doubt it would work too much new stuff has been added and programs most likely depend on them.

A Sun workstation can be very odd hardware wise.