Random internet access

Hi all,
When I use Knetworkmanager to connect to the internet, both the mobile modem (Huawei e220) and Knetworkmanager always indicate that I’m connected. Yet I often can’t access any webpages. I have to close the networkconnection and try again. Sometimes it works after the first try, other times I have to try several times before I get a connection.

Besides konquerer or firefox, the update-applet also cannot access internet. Interestingly, when I can’t access webpages, Ktorrent is still able to connect.

I use Opensuse 11.2 but have had this issue since 10.3. I’m getting tired of sometimes having to try several rounds before being able to connect.

IPv6 is disabled. The proxy settings are always blank (whether I manage to get web-connection or not). I don’t know what else to check. Any suggestions are much appreciated!

What error message are you getting?
What is the output of (when internet working and internet not working):

tail /etc/resolv.conf

This is what I get from: tail /etc/resolv.conf

Internet working correctly


# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 80.251.192.244
nameserver 80.251.192.245

Internet not working, that is not being able to access webpages and yet ktorrent is working


#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!

DNS (nameserver entries in the /etc/resolv.conf) are not getting updated sometimes.

(1) Update your knetworkmanager to the latest version. (There was such issues reported in earlier versions).

(2) Alternatively, you may feed in those nameserver entries manually. (It can also happen that your provider may have a problem sending it while assigning the DHCP address).

I see,

  1. I believe I have the latest version of knetworkmanager. When I was about to upgrade it, yast asked me to solve the issue by downgrading or ignore some dependencies. The versions in yast are marked in red. So I opted for not upgrading it.

  2. How do I feed in the nameservers manually? (Should I contact my serviceprovider about the issue in case it’s them having problems sending it?)

(1) What is the KNetworkManager version?

rpm -qa NetworkManager-kde4

(2) You can feed in the DNS entries in the “IP Address” tab of the KNetworkManager for your connection. Choose “Automatic (DHCP) addresses only” in the ‘Configure’ option.

  1. When quering the version with the command you wrote, I get:

NetworkManager-kde4-0.9.svn1057339-129.25.x86_64

I’m using factory repositories for kde 4.4

  1. I can’t find the IP Adress tab in Knetworkmanager. That is I go to Knetworkmanager > manage connections > mobile broadband > edit (under which I can choose between two tabs; Mobile broadband and PPP. None of them have a field where I can enter the IP adress).

(1) That version is looking OK to me.

(2) Oh, OK, it is not available under mobile broadband. Can you try putting it directly by editing the file: /etc/resolv.conf

  1. So that it looks like this (just want to check before I proceed)?

# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 80.251.192.244
nameserver 80.251.192.245

Remove one more line (as shown below) so that it will not get overwritten automatically:

# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
nameserver 80.251.192.244
nameserver 80.251.192.245

Many thanks syampillai!!

I edited the resolv.conf file as instructed and it now works like a charm!!! lol!

Nice to hear that. You are welcome.