Random gnome-shell crashes


I’m getting some random gnome-shell crashes, can’t link it back to any particular activity, it appears random.

It’s always the same library ‘libgobject-2.0.so.*’

kernel: gnome-shell[6321]: segfault at 55840000000c ip 00007f084fee246d sp 00007ffe25b610c0 error 4 in libgobject-2.0.so.0.6600.7[7f084febb000+2f000]
kernel: Code: 8b 1c d8 48 85 db 0f 84 11 ff ff ff e9 01 ff ff ff 66 66 2e 0f 1f 84 00 00 00 00 00 90 48 83 ec 08 48 85 ff 0f 84 93 00 00 00 <48> 8b 07 48 85 c0 0f 84 af 00 00 00 48 8b 00 48 3d fc 03 00 00 77

Happens under X11 and Wayland.

Any idea how I can troubleshoot this? the information in ‘journalctl --system’ really is insufficient.

This is a fresh install of Tumbleweed with only the following packages installed via Zypper:
snapd gcc make python38-devel dbus-1-glib-devel python38-pycairo-devel cairo-devel python38-gobject-cairo gobject-introspection-devel git s-tui docker docker-bash-completion python38-docker-compose solaar guake lxd neofetch freerdp-wayland bc freerdp

All other apps are snaps or flatpaks.

I really love OpenSUSE and would love to make it my daily OS, but if I cannot troubleshoot this I may have to try Leap, or worst case go back to a Debian based distro, but I’d like to avoid that if possible.

Hi and welcome to the Forum :slight_smile:
Not sure, use nether snap, flatpak or docker here, if you disable the snapd etc, does the issue arise with native applications? What packages are missing to require the need for snap/flatpk?


It’s a bit sporadic, today for example, so far in 5 hours I’ve had no shell crashes. If I were to disable snapd, I’m unsure what I would do for potentially 5+ hours waiting for a possible shell crash.

I think what would be better, is more logging than simply segfault. Is there more gnome logs hidden away somewhere, or a way to increase logging?

The main one is vscode, the flatpak version is useless to me, it runs inside a VM and doesn’t have access to the host or host utilities.

It also doesn’t have access to any libraries on the host, it comes with a minimal set of packages, I think you’ve got to install them within the flatpak or something.

I personally do some development in Docker, and launch stacks on the host within vscode. It is possible to execute commands on the host within the vscode VM, I did that, however was getting a whole bunch of errors.

Other options are installing the RPM version, however that’s a bit of a hack, and doesn’t support auto updates or is easily updateable, and VSCodium, however it doesn’t support many of the extensions.

I decided rather than try to debug that unofficial version of vscode, with all it’s limitations, it’d be better to simple use the officially supported snap version, even if snap is not officially supported on OpenSUSE.

Vscode runs natively here? I use the tarball… AFAIK the rpm should add the repository, so should stay updated via zypper.


What graphics card?

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

Screenshot from 2021-03-07 20-49-35.png

Hmmm, right, the tarball does work, and is easy, I might just use that.
I couldn’t find very clear instructions on installing via RPM, a lot of people debating about the best ways to do it.
No mention of it updating automatically, lots of scripts to clean out files as installing over the top may leave orphaned files there.

Think I might reinstall, use the tarball version of vscode, and everything else via flatpak.

For reference, it’s a Thinkpad T480, so should have good linux support.

00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
Subsystem: Lenovo Device [17aa:225d]
Kernel driver in use: i915
Kernel modules: i915

Just a zypper in should be fine?

Someone may offer advise on the UHD gpu…

Hopefully GNOME 4.0 won’t be far away, have it on a test qemu machine (nvidia gpu though) and running fine :wink: