Random freezes and I don't know what to do!

Hey guys and gals,

Im running 11.1 and my system randomly freezes and i have no idea why or what causes it.

Here’s my best explaination

Dual boot XP and OpenSUSE, everything worked fine and dandy, even the wirelessN right from the start. The system did freeze up the first time I was messing around with the DNS settings of the card. It also froze up now and then at startup when the mouse is the spinning loadwheel with nothing on screen

Then I enabled compiz and from what I beleive, there were 2 different issues:

  1. the system still froze up every 1 out of 3 startups right at the start as stated above.

  2. the screen would freeze when either using Scale or the app that shows you all 4 desktops and you can click on them (i dont remember it’s name). The mouse would still move but I coulnt click on anything. the PC would still be running bcause I could hear the IM alerts in the background. I could recover out of this using ctrl-alt-backspace but not everytime. sometimes that wouldnt work either

and now, the PC freezes up 4 out of 5 times at startup and if it doesnt, it freezes later on during any use.

I dont know what to do! I checked the logs are there doesnt seem to be anything like ERRRRRRORRRRRRR!!! but im a n000000b and wouldnt really know :frowning:

thanks in advance and i hope im not flooding you guys with unneeded info :slight_smile:

Does your Windows install ever crash?

nope, never.

I’m pretty sure the compiz screen freezing but mouse still moving problem is unrelated to the real, more important problem

im also pretty sure that it has something to do with the wireless, as when I DO get into suse, the internet goes reallllly slow and barely works, whereas in windows its fine. but why does it happen only sometimes? why is it happening so much more often now than before?

How easy would it be for me to install madwifi drivers? would i need a wired connection for suse? or could i download the files in windows and boot into suse and install it. if it is the wifi, which i think it is, madwifi might be my solution. the current driver is ath9k.

my card is the Dlink DWA 552 which has an Atheros 5416 chipset.

Did you try the memory check option from the installation disk?

Is the system slow (try the “top” command) or just the browser?

If you disable/remove the wireless card in Yast the system goes back to normal? Or if you blacklist it’s driver?

nope, what would that do? my ram is healthy.

when the internet runs slow, its just the internet, meaning pages dont load, i cant sign into IM etc… though the internet is running fine right now :S

I did disable it, but didnt use the system for long enough to see if it was fine. It might be me messing around with the DNS settings. Im pretty much a linux n00b so i dont know what im doing.
what i was trying to do is make the PC use another DNS server instead of OpenDNS which is what my network uses. My older brother takes care of the home network and has it all locked up with openDNS. no pr0n = bad. lol… its so easy to do this in windows. I just put in as my DNS server in windows and it uses that instead.
I seem to have gotten it in SUSE, pr0n is working :stuck_out_tongue:

Dunno how to do that. It may have been the DNS thing. cause now its working and internet is fine and everything.

Its weird though: at this bootup, it asked my for a resolution after GRUB and showed all the bootup (i.e. there was a lot of commands and words scrolling on screen) instead of the usual green OpenSUSE loadscreen

also, my desktop background randomly goes between 2 default ones :S

Also you should disable IPV6. In Yast > Network Devices > Network config > Global options tab, uncheck the “enable IPV6” box.

i cant really do that if it keeps freezing at startup.

i dont understand! computers arent supposed to be sporadic! yesterday i was on for about an hour, surfing with no problem. today i’ve restarted the PC about 10 times with it freezing everytime at startup. and when i do check the logs, they show nothing!

I also tried starting it in Failsafe Mode, it freezes in that too :frowning: i have no idea what to do

What filesystem are you using? I use reiserFS on my laptop and it works perfectly. However, when i tried to set up reiserFS on my desktop i had the same problem that you described.

maybe this can help someone help me. It’s happened twice:

After booting into windows, using it for a little while and restarting to boot into SUSE, this happens:

it asks to press enter to select a video mode, press space to continue or wait 30 seconds.
then it loads SUSE by showing all the loading, theres a lot of scrolling text and a couple “done”'s on the right side in green
then it gets into SUSE with a different background then normal

its really weird. when this happens, it doesnt seem to freeze and works fine. whats going on?!

im using the default ext3 or whatever its called. i’ll keep that in mind. thank you :slight_smile:

I’ve been looking but can’t find a solution to my problem. its definitely the wireless as when it freezes and i check the logs, the last entry is almost always something to do with wlan0

Dec 28 18:25:54 kernel: wlan0: authentication with AP 00:12:17:aa:6d:** timed out


Dec 28 22:57:21 kernel: wlan0: authentication with AP 00:19:5b:4a:a1:** timed out


Dec 28 23:20:59 kernel: wlan0: deauthenticated

what can I do here? try madwifi or is there some fix for this?

thanks in advance.