Random disconnection and other Issues (OpenSUSE 13.2 / Atheros AR9227)

Hello to all :smiley:

I’m having problem connecting with my wireless. This are the symptoms in descending order of frequency:

  • Gets randomly disconnected, asking me for the password many times although it’s stored and I entered it right.
  • It connects but it’s really slow.
  • It connects to the router but I can’t acess internet (Network Manager
    shows that I’m connected) - My AccessPoint
    dissapear from the list on NetworkManager, have to disable and re-enable Wireless to make it show again.

I never had any problems in OpenSUSE 12.3 with my Kozumi (Marvell 88w8335) using NdisWrapper. I had to change the card for a TP-Link one because the **Kozumi **was working bad with OpenSUSE 13.2 (Betweeen 1% and 7% of signal strength). Unfortunately I still have connection issues.

I don’t have any problems with all the other devices I use to connect to this router, all work without issues and at good speed. The PCI card works well in Windows.

Wireless PCI Card Info:

Model: TP-Link TL-WN751ND

01:06.0 Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)
Subsystem: Qualcomm Atheros Device 0301
Flags: bus master, 66MHz, medium devsel, latency 168, IRQ 18
Memory at dbff0000 (32-bit, non-prefetchable) [size=64]
Capabilities: [44] Power Management version 2
Kernel driver in use: ath9k
Kernel modules: **ath9k
**

System Info:

OpenSUSE 13.2 KDE
Linux 3.16.7-7-desktop
#1 SMP PREEMPT Wed Dec 17 18:00:44 UTC 2014 (762f27a) GNU/Linux

Further info:

iwconfig

wlan0 IEEE 802.11bgn ESSID:“Censored :P”
Mode:Managed Frequency:2.462 GHz Access Point: 04:28:4X:30:39:F1
Bit Rate:18 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=22/70 Signal level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:260 Invalid misc:7048 Missed beacon:0

Shouldn’t it say Encryption key: on ?

dmesg | egrep ‘ath|wifi|hal’

tlb_flushall_shift: 6
9.451715] ath: EEPROM regdomain: 0x809c
9.451720] ath: EEPROM indicates we should expect a country code
9.451722] ath: doing EEPROM country->regdmn map search
9.451723] ath: country maps to regdmn code: 0x52
9.451725] ath: Country alpha2 being used: CN
9.451726] ath: Regpair used: 0x52
51.710124] ath9k 0000:01:06.0 wlan0: disabling HT/VHT due to WEP/TKIP use
51.710133] ath9k 0000:01:06.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
51.710137] ath9k 0000:01:06.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP

I have tried configuring the card on Yast. Deleting it and reconfiguring it. Using Wicked instead of **NetworkManager **as the Network Setup Method and trying to connect with Yast Network Settings. Same random disconnection problems, had to enter rcnetwork restart on the terminal to reconnect.

I have tried disabling Wicked and enabled NetworkManager using the method in the Release Notes of OpenSUSE 13.2.

I have tried connecting through the terminal with iwconfig.

Nothing have worked. I hope this problem can be solved, I don’t want to get back to Windows after spending two years with OpenSUSE.
I hope I have posted this right I’m new to the forum.
Thanks in advance :)[/size]

Have similar symptoms on one Toshiba notebook, with a RTL8188EE controller–except the speed is ok as long as it is connected.

The network manager window brought up by the Plasma widget regularly fails to show my Wi-Fi AP in the first notebook computer. The connection is lost and all DNS queries (of course) can’t find the server. The green ‘refresh’ icon has no effect. When my AP does show up, the signal level is 50-65%.

Another Roshiba notebook (running identical OS and s/w, with Centrino Wireless-N 1000 chip) shows a signal strength of about 55% all the time and almost never drops the wi-fi connection .

On the problem computer, the prompt from networkmanager for the pass phrase (WPA2-PSK) is always blank. This requires other users to come to me for help. I’d like to make the wi-fi connect automatically, as it did earlier. Have not used kwallet.

Suggestions welcome.

Using plasma-nm 0.9.3.4 on openSuse 13.2 and KDE 4 (4.11 and 4.12 components). Everything comes from openSuse repositories.

A little update:
I stopped using KDE NetworkManager or Wicked/Yast Network Settings****, and started to connect using wpa_supplicant from the terminal using a custom config file. To connect every time that I boot up I have to go to the terminal and launch wpa_supplicant and dhcpcd wlan0, then I’d use wpa_gui.
One day I boot up and it was automatically connected to the net. I didn’t have to run the commands like all the other times. I don’t even know why it changed like this.
I still suffer from disconnection problems.

Some log info of a disconnection (back when I was still using KDE NetworkManager):

tail -f /var/log/wpa_supplicant.log

wlan0: CTRL-EVENT-SCAN-STARTED
wlan0: CTRL-EVENT-SCAN-STARTED
wlan0: CTRL-EVENT-SCAN-STARTED
wlan0: SME: Trying to authenticate with 04:28:4X:30:39:F1 (SSID=‘CensoredWIFI’ freq=2462 MHz)
wlan0: Trying to associate with 04:28:4X:30:39:F1 (SSID=‘CensoredWIFI’ freq=2462 MHz)
wlan0: Associated with 04:28:4X:30:39:F1
wlan0: CTRL-EVENT-DISCONNECTED bssid=04:28:4X:30:39:F1 reason=15
wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid=“CensoredWIFI” auth_failures=1 duration=10 reason=WRONG_KEY
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD

journalctl -l

Apr 08 23:18:20 madbasque dhclient[3142]: DHCPREQUEST on wlan0 to 192.168.0.1 port 67 (xid=0x17ae42ec)
Apr 08 23:18:20 madbasque NetworkManager[853]: DHCPREQUEST on wlan0 to 192.168.0.1 port 67 (xid=0x17ae42ec)
Apr 08 23:18:21 madbasque NetworkManager[853]: <info> (wlan0): DHCPv4 state changed renew -> renew
Apr 08 23:18:21 madbasque nm-dispatcher[4656]: Dispatching action ‘dhcp4-change’ for wlan0
Apr 08 23:25:01 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: completed -> disconnected
Apr 08 23:25:01 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Apr 08 23:25:01 madbasque kernel: wlan0: authenticate with 04:28:4X:30:39:F1
Apr 08 23:25:01 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 1/3)
Apr 08 23:25:01 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Apr 08 23:25:01 madbasque NetworkManager[853]: <info> (wlan0): roamed from BSSID 04:28:4X:30:39:F1 (CensoredWIFI) to (none) ((none))
Apr 08 23:25:02 madbasque kernel: wlan0: authenticated
Apr 08 23:25:02 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Apr 08 23:25:02 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Apr 08 23:25:02 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Apr 08 23:25:02 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 1/3)
Apr 08 23:25:02 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: authenticating -> associating
Apr 08 23:25:02 madbasque kernel: wlan0: RX AssocResp from 04:28:4X:30:39:F1 (capab=0x411 status=0 aid=3)
Apr 08 23:25:02 madbasque kernel: wlan0: associated
Apr 08 23:25:02 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: associating -> associated
Apr 08 23:25:02 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
Apr 08 23:25:04 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: 4-way handshake -> disconnected
Apr 08 23:25:04 madbasque NetworkManager[853]: <info> Activation (wlan0/wireless): disconnected during association, asking for new key.
Apr 08 23:25:04 madbasque NetworkManager[853]: <info> (wlan0): device state change: activated -> need-auth (reason ‘supplicant-disconnect’) [100 60 8]
Apr 08 23:25:04 madbasque nm-dispatcher[4763]: Dispatching action ‘down’ for wlan0
Apr 08 23:25:04 madbasque NetworkManager[853]: <info> (wlan0): supplicant interface state: disconnected -> inactive

Now using wpa_supplicant and wpa_gui. Log info about when it got disconnected twice:

journalctl -l | grep wlan

Jun 22 22:02:47 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:02:47 madbasque kernel: wlan0: RX AssocResp from 04:28:4X:30:39:F1 (capab=0x411 status=0 aid=3)
Jun 22 22:02:47 madbasque kernel: wlan0: associated
Jun 22 22:05:53 madbasque kernel: wlan0: deauthenticated from 04:28:4X:30:39:F1 (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)
Jun 22 22:06:11 madbasque kernel: wlan0: authenticate with 04:28:4X:30:39:F1
Jun 22 22:06:11 madbasque kernel: wlan0: direct probe to 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:06:11 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 2/3)
Jun 22 22:06:11 madbasque kernel: wlan0: authenticated
Jun 22 22:06:11 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Jun 22 22:06:11 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Jun 22 22:06:11 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Jun 22 22:06:11 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:06:11 madbasque kernel: wlan0: RX AssocResp from 04:28:4X:30:39:F1 (capab=0x411 status=0 aid=3)
Jun 22 22:06:11 madbasque kernel: wlan0: associated
Jun 22 22:08:06 madbasque kernel: wlan0: authenticate with 04:28:4X:30:39:F1
Jun 22 22:08:06 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:08:07 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 2/3)
Jun 22 22:08:07 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 3/3)
Jun 22 22:08:07 madbasque kernel: wlan0: authenticated
Jun 22 22:08:07 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Jun 22 22:08:07 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Jun 22 22:08:07 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Jun 22 22:08:07 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:08:07 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 2/3)
Jun 22 22:08:07 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 3/3)
Jun 22 22:08:07 madbasque kernel: wlan0: association with 04:28:4X:30:39:F1 timed out
Jun 22 22:08:18 madbasque kernel: wlan0: authenticate with 04:28:4X:30:39:F1
Jun 22 22:08:18 madbasque kernel: wlan0: direct probe to 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:08:18 madbasque kernel: wlan0: send auth to 04:28:4X:30:39:F1 (try 2/3)
Jun 22 22:08:18 madbasque kernel: wlan0: authenticated
Jun 22 22:08:18 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Jun 22 22:08:18 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Jun 22 22:08:18 madbasque kernel: ath9k 0000:01:06.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Jun 22 22:08:18 madbasque kernel: wlan0: associate with 04:28:4X:30:39:F1 (try 1/3)
Jun 22 22:08:18 madbasque kernel: wlan0: RX AssocResp from 04:28:4X:30:39:F1 (capab=0x411 status=0 aid=3)
Jun 22 22:08:18 madbasque kernel: wlan0: associated

Anyone has any idea why I keep getting disconnected? :frowning:

Hi. You could try using wpa_supplicant and wpa_gui to manage the network instead of using Network Manager. That way it succesfully remembers the password (contrary to Network Manager).