Ralink rt2870 too slow with 11.2

Hi everybody,

I have a Ralink rt2870 chip. Since it did not work with 11.2 out of the box (should it not be in the kernel?), I had to install this driver from the software search area on opensuse.org:

This package contains binary firmware images for Ralink WLAN cards with rt61/rt73/rt2860/rt2870 chip in combination with the rt2x00-drivers from the serialmonkey-project.
The firmware files will be copied to /lib/firmware.
noarch ralink-firmware-1.1-1.1.noarch.rpm

After installing it, it works, but only at reduced speed, (I think), because when keeping the mouse over the list item (of that connection) in Network Manager, a window pops up saying I only have 54Mbit/s. It says:

Type: WiFI
Interface: ra
Hardware adress: 00:15: …
Driver: usb
Status: connected
Bit rate: 54 Mbit/s

Thanks for any help or suggestion!


I run also Ralink rt2870 and on instalation Suse load all the drivers and firmware. It finds access point and all however it does not connect, even system tray icon shows correct name and strenght. I tried it under windows and discover that there it works on 64 Mbit/s being a few inches direct vision of the router. So maybe reason it is not in linux.