Ralink RT2561 PCI - Drivers installed, Can't ifup

After trying for days with wireless dongles I finally buckled and bought a card that’s suppose to work well with linux. It installed easily enough and I downloaded and compiled the latest drivers from Ralink. Unfortunately neither ifup or Network manager can scan or connect to any network.

ifup wlan0 returns:

wlan0 device: RaLink RT2561/RT61 802.11g PCI
command ‘iwconfig wlan0 nick Reki’ returned Error for wireless request “Set Nickname” (8B1C) :
Set failed on device wlan0 ; Operation not supported.
Starting DHCP client daemon on wlan0… . . . . . . . . . . . . . . . no IP address yet. . . backgrounding.
interface wlan0 is not up.

The os is Opensuse 11 using kde and the kernel is .

Any help will be greatly appreciated.

You do not need to compile any drivers at all. Ralink’s RT61 Chipsets work out of the box! The problem is… the firmware is missing in openSUSE’s default installation. Grab it here http://www.ralinktech.com.tw/data/RT61_Firmware_V1.2.zip and copy the bin-files (the firmware) to /lib/firmware and reload the kernel module or reboot.

Happy networking!


Did you get your card working?

I’ve also got a rt61 and despite it being said that these cards work out of the box mine didn’t.

To get it to work I first downloaded the rt61-cvs-daily.tar.gz from http://rt2x00.serialmonkey.net

I compiled these then made sure I took out the existing driver from the kernel using “rmmod rt61pci” then did a “modprobe rt61” to put the new driver in.

Once I had done that I just configured it in yast and it worked perfectly.

There were a few more steps for setting up the kernel sources before compiling but I’m at work at the minute and can’t remember off hand everything but if you’re still stuck let me know and I’ll get some better instructions.


Some more info:

Follow these instruction but substitute rt61 wherever it says rt2500.
10.3 & Rt2500 Wireless Howto - openSUSE Forums
Thats all I did.


Didn’t work but i copied the firmware to the specified directory and i managed to download source for the drivers.

Then i did a cp Makefile.6 Makefile
then $chmod 777 Makefile
then $dos2unix Makefile
then $./Makefile

That went ok
then $ make
apart from a few warnings that went ok too then I did a
$ make install
that seemed to go ok too
then $ifup ra0

The system reported that ra0 was not configured

I tried $iwconfig ra0
it responded that ra0 had no wireless extentions

hmm. Any ideas what went wrong?


Guys, all compiling is not needed at all, trust me. Just follow my “tutorial” (second post) carefully and it’ll work 100% with the stock drivers shipped with openSUSE 11.0 (and 10.3)

I must be going blind but i can’t see your tutorial.
Is that the bit on this thread or is it a seperate post?

I got the card to spot the wireless network. I still get the firmware warning despite the fact that i installed the firmware to the specified location and i have to use the KNetworkManager to bring up the interface rather than ifup.
Even then i have to manually add the routing info as it seems to ignore the routing tables

perhaps i could put the route commands in one of the scripts inside the script directory. Or is that bodging?

Did as they said - downloaded the .zip archive
extracted to /lib/firmware. rebooted and it is up.

nothing fancy…