Radon/fglrx driver 11.3/11.4 (x64) and mouse pointer problem with 2. kde session


Card: ATI (RV730 9490)
System: 11.3_x64 / 11.4_x64
Desktop: KDE

In 11.3 the radon driver always was loaded even if it was added in /etc/modprobe.conf/fglrx.conf file not to load.
Now in 11.4 this works fine and you don’t have to specify nomodeset as kernel boot option and it works out of the box.
Thanks a lot!
But now it’s the other way round. It’s impossible to load the radeon driver.
I have disabled to load fglrx driver in /etc/modprobe.d/fglrx.conf

Other problem in 11.3 radeon driver hat max. resolution of 1200x1024 for my system where the fglrx driver has 1600x1200 but fglrx driver flickers tremendous in google-eaerth.
This seems to be also solved in 11.4

What I have is a strange issue if you have a second session in 11.4.

The first session always is ok even you switch several times to the second session and the other way round.
But the second one has some problems.

  1. the bottom right edge is mangled (about 1/6 of the length almost all Taskbar icons)
  2. The most problem is that the mousepointer disappears if there is an “update” of an “other” X11 event it seems.
    For example you point the mouse over “Desktop Folder” and the “Modify-Tab” comes on, the mouse pointer goes away if you move the mouse it appears again.
    To reproduce this error you can start xosview and the mouse pointer disappears “always” because update of xosview…
    This is very bad because for example it’s very difficult to put an window in the background when configured with a mouse button :frowning:
    This seems to be a kde problem because it does not exit with IceWn nor with Twm

Is this already a known bug?



Nobody having this issue?
No solution?

BTW: google-earth is still flickering. No idea why sometime it works for some time after starting, sometime not even at startup works…

I can’t help you much, but I remember that there is some problem with fglrx driver version and xorg version for 11.3. But 11.3 never worked for me, so I used Mint till 11.4 came out.
However, in 11.4 things go smooth. I had no problem in returning from one fglrx installation to radeon, but I didn’t disabled it, but uninstalled it. You must be in init 3 mode when doing it.
Then, I had Oldcpu explaining how to install driver again in his way, and eversince, no problem whatsoever.