radeonhd

Hi all.
How to properly configure radeonhd driver?
Overall performance is good but fullscreen video playback is slow. Any solution/ideas?

I’m no video guru, but some basic suggestions to start with…

Do you have Compiz_Fusion enabled? Optimizing video playback involves selecting the appropriate video backend for for your video player aplication(s). I note you are using the OSS driver. Can you post your xorg.conf. Maybe there is something that can be tweaked.

For MPlayer, select Preferences > Video. Select X11 (XImage/Shm)

If using xine, you need to set ‘xshm’ option.

Similar kind of discussion here.

Nope, I’m not using compiz fusion. I have a clean installation of openSUSE 11.0 with default xorg.conf:

BoardName “ATI Radeon HD 2400 PRO AGP”
BusID “1:0:0”
Driver “radeonhd”
Identifier “Device[0]”
Option “monitor-VGA_1” “Monitor[0]”
VendorName “ATI”

What options can you advise to add?
Maybe smth like:

Option “TexturedVideo” “off”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”

I had these options in slackware linux, which helped to solve issue with video playback.

Sorry, but your methods didn’t work(

They’re not my methods actually, just some general advice for those using OSS drivers (and low-end graphics hardware). It is important to note that the readeonhd driver is still being developed (by Novell et al), and doesn’t yet have 2D or 3D acceleration capability, so it may be a case of waiting. Some info here.

Check out:

RadeonHD.org | IRC Archives For The Radeon & RadeonHD Drivers