Radeon HD 8850M / R9 M265X on openSUSE 13.2 x64


i am unable to install the latest fglrx driver on my opensuse 13.2 x64 laptop

installed software : https://mega.co.nz/#!pZVDzApA!TurWUJJVC7Hop--sGk7in1iJqcwRIa5ev2TzAlzDJNY
laptop hardware : https://mega.co.nz/#!cE1BGQQL!9naaLTiJW-fp1BzIHiIIs8z5DF56MKN15bNIUfWjzoI
xorg log : https://mega.co.nz/#!MIEXETwJ!C_b14acRc3TtacvRi7WANcJZ5DKETY4w7mtAJcvjDcY

any idea what i am doing wrong???


Well, I have no idea what you’re actually doing in the first place, so I don’t know what you’re doing wrong… :wink:

Anyway, you don’t have any fglrx package installed, so you downloaded the driver from AMD directly?
Try to uninstall it again and try to install it using the openSUSE packages:

OTOH, according to your X log, the crash seems to be caused by the intel driver actually.
Maybe try to disable that by adding “nomodeset” to the kernel options, but I have no idea how well this would work on an AMD/intel hybrid system.

You could also try to rename the /etc/x11/xorg.conf, this file should not be necessary and might cause problems.

if downloaded and installed the driver from http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/. I followed the instructions on https://en.opensuse.org/SDB:AMD_fglrx. I always was unable to start the xorg-server. finally i delete the fglrx driver and every thing is working.

what i am actrually try to do is to install the fglrx driver.

So you did install the RPM packages?
They are not listed in your package list, that’s why I suggested that.

Anyway, have you tried the other things I suggested?
I know about similar reports from other users (all seem to use i965 IIANM), but I don’t really know a solution.

I had another look in your Xorg log, and it looks to me that you are using UXA acceleration for the intel driver instead of the default SNA.
I know that this was advised on 13.1 to prevent certain problems with the intel driver, but I also know that (some) people doing that had problems after upgrading to 13.2. So try to switch back to SNA if possible.

Oh, and one additional question: how do you actually start the X server?
According to your Xorg log, you boot to runlevel 3, i.e. text mode.

what i am actrually try to do is to install the fglrx driver.

Yes, this was obvious. But how exactly was not clear.

And my comment was not meant completely serious. Didn’t you notice the smiley? :wink:

yes i did.

yes i did, no result.

sorry i don’t understand. i only do a clean install from official iso on my new laptop.

yes i did. when the xorg.server crashed i boot to text mode and try to start manual the xserver after the second fail, i unistalled the fglrx packages, i copy the log file and i boot again with default settings and radeon driver.

Well, I thought you maybe did something like this:
Because the log mentioned UXA whereas SNA should be the default nowadays.

But then, this wouldn’t work anyway on a hybrid system I suppose.

I’m afraid I can’t really help you, I know next to nothing about those hybrid systems (but that crash backtrace looks familiar, I’ve seen it here already: https://forums.opensuse.org/showthread.php/502942-Xorg-Segfault-with-AMD-Intel-Hybrid-on-13-2-using-fglrx but there’s no solution there either and neither in another thread in the Arch forums I found).

But, are you using GNOME (and gdm in particular) by change?
Apparently gdm seems to crash atm when fglrx is installed.
So if you use that, try switching to xdm as a test (set DISPLAYMANAGER=“xdm” in /etc/sysconfig/displaymanager, either with a text editor or YaST->System->/etc/sysconfig Editor).

And another thing: have you installed all updates?
There were updates to the intel driver and the kernel (part of the intel driver is in the kernel) which fix some problems/crashes with intel.

PS: the same (or at least quite similar) crash has been reported here: https://bugzilla.opensuse.org/show_bug.cgi?id=909861 It’s been confirmed today (and hopefully investigated) by openSUSE’s Xorg maintainers…

this is excacly what i am dealing with

Same problems on Toshiba Satellite for almost 4 months now … I am using SuSE since 1999, and so far had no issues.
Is there a generational change going on here, as suse seems to be lagging behind …


System Information
Manufacturer: TOSHIBA
Product Name: Satellite S70-B
Version: PSPPNU-05R00W
Wake-up Type: Power Switch
Family: Arion 10SQ/10SQG

lspci -nn | grep Radeon
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] [1002:6823] (rev ff)

│ ├┬─Haswell Integrated Graphics Controller
│ │├──Bus: PCI
│ │├──Class (spec): VGA-compatible controller
│ │├──Class: Display controller
│ │├──Device Identifier (spec): 129333
│ │├──Device Identifier: 66582
│ │├──Device: Haswell Integrated Graphics Controller
│ │├──Driver: i915
│ │├+─Drivers
│ │├──Hwcfg Bus: pci
│ │├──Kernel Driver: drm
│ │├──Model: Intel Haswell Integrated Graphics Controller
│ │├──Old Unique Key: 6yQN.LVQN_UT3mrF
│ │├+─Resources
│ │├──Revision: 6
│ │├──Slot ID: 2
│ │├──Subvendor Identifier: 70009
│ │├──Subvendor: Toshiba America Info Systems
│ │├──Sysfs ID: /devices/pci0000:00/0000:00:02.0
│ │├──Sysfs ID: 0000:00:02.0
│ │├──Unique Key: _Znp.LVQN_UT3mrF
│ │├──Vendor Identifier: 98438
│ │├──Vendor: Intel Corporation
│ │└──modalias: pci:v00008086d00000416sv00001179sd0000F935bc03sc00i00
┬─Radeon HD 8800M Series
│ ├──Bus ID: 1
│ ├──Bus: PCI
│ ├──Class (spec): Display controller
│ ├──Class: Display controller
│ ├──Device Identifier (spec): 129333
│ ├──Device Identifier: 92195
│ ├──Device: Radeon HD 8800M Series
│ ├──Driver: radeon
│ ├+─Drivers
│ ├──Hwcfg Bus: pci
│ ├──Kernel Driver: drm
│ ├──Model: ATI Radeon HD 8800M Series
│ ├──Old Unique Key: L65w.hepJBtoYiOE
│ ├──Parent Unique ID: vSkL.kF_yXyMlD63
│ ├+─Resources
│ ├──Revision: 255
│ ├──Subvendor Identifier: 70009
│ ├──Subvendor: Toshiba America Info Systems
│ ├──Sysfs ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
│ ├──Sysfs ID: 0000:01:00.0
│ ├──Unique Key: VCu0.hepJBtoYiOE
│ ├──Vendor Identifier: 69634
│ ├──Vendor: ATI Technologies Inc
│ └──modalias: pci:v00001002d00006823sv00001179sd0000F935bc03sc80i00

Hm? What do you mean?
It’s not suse that’s “lagging behind”, it’s AMD that are apparently unable to release a fully working proprietary driver…

That said, a new Beta driver has been released recently, it should hopefully have those problems fixed.
You can use Sebastian Siebert’s latest script to install it:
Please ask if you need help because the page is in german.
But the main steps are explained here as well, you’d just have to change the name of the script: