Radeon HD 6xxxxM driver problems...

Hello. I have hp probook with Radeon HD 6370m but Official driver isn’t working. please help me
using OpenSuSE 11.4 64 bit with GDM

…zzzzzzzz :(((

After 20 minutes ?

ik90 this is a forum run by unpaid volunteer enthusiasts. We are not paid. Your impatient reply suggests me you do not know that.

Have patience and some one will reply.

If you have no patience for this then I suggest you try the IRC chat channel: freenode #suse.

LOL, what are those zzzzzs for? this is not an online chat! and no one here is paid to sit and wait for your question so they can jump on it…

you might have taken the 18 minutes between your post to try to explain your problem…because i have no idea what it is!

you write “I have hp probook with Radeon HD 6370m but Official driver isn’t working.” but, what does that mean?

-3D is not working?

-multiple screens is not working?

-video is upside down?

-video is full of artifacts? smears?

-no video at all?
–blank screen no cursor?
–blank screen blinking cursor?
–white screen?

-desktop effects not working?

-can’t boot and have a error message saying “Radeon HD 6370m Official driver not working”

so, how about you give us some info:

  1. What desktop environment & version? yes, i see GDM, that is window manager…which desktop environment and version

  2. The problem/symptom you describe: did it begin immediately after initial install, or did it come suddenly, some time later?

*if immediately, these would be useful to know:

-Was it installed from media downloaded from software.opensuse.org, or some other place? Where?

-Did you md5 or sha1 check the .iso prior to burning the install disk?

-Did you do this http://tinyurl.com/2ebcf27 before install attempt? (if not, please, boot from the install media, do it now and report results)

-is this a fresh format and install system? or, did you upgrade (keeping any partitions from a former install of Linux? which distro/version was the former version?)

*if it worked ok for a while:

-did this problem begin after a particular update or install?

-if you use YaST to add a new test user, and then log in as that user do you see the same symptom?

in either case (new problem or beginning immediately after initial install) we need to know what it the “Official driver” which is installed but “not working”?

that info would help us, help you…

and, i’ll zzzzzzzzzz a while

I do not believe the Radeon nor the Radeonhd open source drivers have support for the Radeon HD 6370m. Likely this will work (with poor performance) with the FBDEV and/or VESA driver. You can likely get the FBDEV driver to load by booting with the “Failsafe” setting or with the boot code “x11failsafe”.

Possibly the proprietary AMD driver may have support for this hardware. You can download it by going to this page: ATI Catalyst™ Proprietary Display Driver

And the release notes provide instructions on how to install the driver: http://www2.ati.com/relnotes/Catalyst_11.5_Linux_Installer.pdf

There are also MANY other ways to install the same driver.

Install drm-radeon-kmp-{flavor} package and update other packages from home:jobermayr.
(Index of /repositories/home:/jobermayr)

You should then even have 3D support …

On 06/15/2011 08:06 PM, jobermayr wrote:
> You should then even have 3D support …

is he missing 3D support???


If he terms the radeon driver as “Official driver” then yes (3rd and 5th en-dash):
[Phoronix] Update On The HD 6000 Series Open-Source Support](http://www.phoronix.com/scan.php?page=news_item&px=ODk5MQ)


system is working fine but everything is accelerated by cpu. 3D works very poor and when I install official amd driver acceleration is terrible

There are many versions of the official AMD drivers. Which version do you have installed ?

There was in fact a new version of the proprietary AMD driver released yesterday. Do you have that version installed ?

When you say poor , … poor compared to what ? If compared to MS-Windows that is no surprise as the performance of the GNU/Linux graphic drivers provided by Graphic hardware suppliers (AMD and nVidia) are notorious for being slow compared to their MS-Windows graphic driver counter parts.

Did you run the Catalyst Control panel to try and tune the performance ?

tried but not working…

I haven’t tried newest version.

I tried this >>> ATI Catalyst™ Proprietary Display Driver

That is updated everytime there is a new version. If you LOOK at it then you will see it refers to Catalyst 11.6. It was updated yesterday from 11.5 to 11.6. But just pointing to that URL does not tell us what Catalyst version you have installed.

Do you not know how to figure out what Catalyst version you have installed and do you need someone to explain how to you?

No I don’t need help to install this but if I’ll have problems I’ll post

I installed newest (06/17/2011) ati driver and catalyst control panel… but
bad news…

my screen:


this blue square is cursor. I can move it!! :smiley:
thanks ati for newest driver :slight_smile:
I am really happy now :|||

That does not look good.

Did you check the /var/log/Xorg.0.log file to see if it gives any hints as to the problem ?

Did you try without the /etc/X11/xorg.conf ? Did you try to create a custom /etc/X11/xorg.conf with the aticonfig tool ?

Did you try tuning with the Catalyst control center to remove the problem ?

I installed and rebooted. I didn’t created and configured something…
Now I cant access my opensuse. even cant open “tty” (ctrl + alt + F1-…)

Hmmm … simply reboot DIRECT to run level 3 (do NOT go there via X) and fix/restore things.

I’m thinking you need guidance there ?

Oh please help…
How can I boot without X
and okay if I boot my opensuse without X
what can I do next?

Boot your PC direct to run level 3. You do that by pressing ‘3’ when the grub boot/splash menu appears so that the ‘3’ will show up in the options line. ie similar to this (but not the same):
[click on image for larger view]

In fact if it were me, I would type “nomodeset 3” and not just “3”. The idea is I may want to do some things in run level 3 that requires ‘nomodeset’ in place.

That will take you to a full screen text mode. Login as a regular user. Here you have many choices. Some ideas:.

  • diagnose problem by looking at /var/log/Xorg.0.log file with an editor such as midnight commander (mc). If not installed, just install it with root permissions with “zypper in mc” (assuming one has wired Internet access).
  • and/or with ‘mc’ edit the /etc/X11/xorg.conf file (if it exists) or remove the file (both with root permissions). Or create a new file with root permissions:
aticonfig --initial 
  • and/or remove the fglrx (Catalyst) driver. First find out what driver is installed. Do so with command:

rpm -qa '*fglrx*'

and say it is the fglrx64_xpic_SUSE114-8.861-1.x86_64.rpm (it may be different), then remove that file with (root permissions):

rpm -e fglrx64_xpic_SUSE114-8.861-1.x86_64.rpm

and now with that rpm removed, you can re-install it, or an earlier version. Or you could rebuild the fglrx driver again by running the appropriate ati script.

Its possible when you built the driver the 1st time you did not disable mode setting which may have caused your problem (I simply do not know).

  • and as an interim you could edit the /etc/X11/xorg.conf.d/50-device.conf file and insert ‘vesa’ or ‘fbdev’ in place of ‘radeon’ and uncomment that line, so as to boot to either of those drivers. You can easily do such an edit with midnight commander.

Then when it comes to rebooting type with root permissions:

shutdown -r now

or halt with

shutdown -h now