Radeon HD 5670 (evergreen, redwood) very slow

Hi, all

After installing 11.3 on a computer with a Radeon HD 5670 the graphical interface is extremely slow. It is so slow that at first I thought that it was using the vesa driver or something like that.

However, after reading /var/log/Xorg.0.log, it seems that the radeon driver is actually being used after all.

output from “dmesg | grep \[drm\]”:

    1.576780] [drm] Initialized drm 1.1.0 20060810
    1.639287] [drm] radeon defaulting to kernel modesetting.
    1.639417] [drm] radeon kernel modesetting enabled.
    1.641950] [drm] initializing kernel modesetting (REDWOOD 0x1002:0x68D8).
    1.642610] [drm] register mmio base: 0xFDEC0000
    1.642721] [drm] register mmio size: 131072
    1.643169] [drm] Clocks initialized !
    1.643278] [drm] 1 Power State(s)
    1.643385] [drm] State 0 Default (default)
    1.643494] [drm]    16 PCIE Lanes
    1.643600] [drm]    1 Clock Mode(s)
    1.643707] [drm]            0 engine/memory: 775000/1000000
    1.643832] [drm] radeon: power management initialized
    1.644586] [drm] Detected VRAM RAM=256M, BAR=256M
    1.644716] [drm] RAM width 128bits DDR
    1.652080] [drm] radeon: 256M of VRAM memory ready
    1.652191] [drm] radeon: 512M of GTT memory ready.
    1.653788] [drm] Radeon Display Connectors
    1.653897] [drm] Connector 0:
    1.654002] [drm]   DisplayPort
    1.654107] [drm]   HPD4
    1.654211] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
    1.654376] [drm]   Encoders:
    1.654481] [drm]     DFP1: INTERNAL_UNIPHY2
    1.654589] [drm] Connector 1:
    1.654693] [drm]   HDMI-A
    1.654795] [drm]   HPD5
    1.654899] [drm]   DDC: 0x6470 0x6470 0x6474 0x6474 0x6478 0x6478 0x647c 0x647c
    1.655064] [drm]   Encoders:
    1.655168] [drm]     DFP2: INTERNAL_UNIPHY2
    1.655275] [drm] Connector 2:
    1.655379] [drm]   DVI-I
    1.655482] [drm]   HPD1
    1.655586] [drm]   DDC: 0x6450 0x6450 0x6454 0x6454 0x6458 0x6458 0x645c 0x645c
    1.655751] [drm]   Encoders:
    1.655855] [drm]     DFP3: INTERNAL_UNIPHY1
    1.655962] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    1.924182] [drm] fb mappable at 0xC0040000
    1.924293] [drm] vram apper at 0xC0000000
    1.924399] [drm] size 3145728
    1.924502] [drm] fb depth is 24
    1.924608] [drm]    pitch is 4096
    1.974253] [drm] Initialized radeon 2.3.0 20080528 for 0000:02:00.0 on minor 0

output of “dmesg | grep radeon”:

    1.639668] radeon 0000:02:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
    1.639812] radeon 0000:02:00.0: setting latency timer to 64
    1.642330] radeon 0000:02:00.0: PCI: Disallowing DAC for device
    1.642446] radeon: No suitable DMA available.
    1.643964] radeon 0000:02:00.0: VRAM: 256M 0x00000000 - 0x0FFFFFFF (256M used)
    1.644182] radeon 0000:02:00.0: GTT: 512M 0x10000000 - 0x2FFFFFFF
    1.973813] fb0: radeondrmfb frame buffer device

output of “dmesg | grep agp”:

    0.984394] Linux agpgart interface v0.103
    1.345832] agpgart: Detected VIA P4M900 chipset
    1.361728] agpgart-via 0000:00:00.0: AGP aperture is 256M @ 0xd0000000


reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
reg01: base=0x0d0000000 ( 3328MB), size=  256MB, count=1: write-combining
reg02: base=0x07ff00000 ( 2047MB), size=    1MB, count=1: uncachable
reg03: base=0x0c0000000 ( 3072MB), size=  256MB, count=1: write-combining

The Xorg.0.log file is quite big, but grepping just (EE) and (WW) yields:

   822.095] (WW) RADEON(0): Color tiling is not yet supported on R600/R700
   822.248] (WW) RADEON(0): Direct rendering disabled

I tried running with the nomodeset flag on boot and other suggestions from wiki:SDB:Configuring_graphics_cards to no avail. From what I could understand, this card is only supported by the radeon driver and this driver in turn requires KMS to work.

As a last resort, I even tried to install the proprietary driver, but it seems the kernel (or Xorg, or something) shipped with 11.3 is too recent for the catalyst install script:

which: no XFree86 in (/home/<user>/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin)

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.34-12-default:; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.a8TyU0

If you need more information or want me to try something, please let me know. Thanks in advance,

While waiting for ATI to produce a proprietary driver that will work with openSUSE-11.3’s 2.6.34 kernel with Xorg-1.8.0, I recommend you write a bug report on the openSUSE-11.3 implementation of the radeon driver. There is guidance here for writing bug reports: Submitting Bug Reports - openSUSE

I started by asking here, because this might not be a bug, just something I’ve done wrong in the first place.

However, it seems the problem doesn’t affect only my graphics board. Someone with a different board had already reported bug 616418. I just added a comment and a vote to that bug report.

I looked at the config files you provided, and that suggested to me (1) you knew what you were talking about and (2) its a bug as this should work better with that hardware (its nice hardware). :slight_smile:

I think adding an extra comment helps in a case like this, as it gives more credence to the bug report, in that one is less likely to think its a newbie error causing the problem (and I think its a problem with the radeon driver or the kernel interaction with it).

At the risk of being flamed :slight_smile: … you could try downloading a Fedora-13 liveCD iso file, burn it to CD and then see how Fedora-13 runs. My experience with Fedora-13 is they have some patches to both the kernel and the radeon driver that openSUSE has not applied in 11.3 (likely because the patches have not yet been accepted upstream, and hence have not made it back downstream as approved). If Fedora-13 works better with the radeon driver on your hardware, then mention it in the bug report.

On different (legacy) ATI hardware, I have discovered Fedora-13’s radeon driver works better than that of openSUSE, and I raised a bug report, and to help in the bug report resolution I provided to that openSUSE bug report (I raised) information as to what patches Fedora has applied. Thus far that has not helped solve the problem I reported, but I think it a step in the right direction. :slight_smile:

Good luck.

Thanks :slight_smile:

Oh, the profanity!!! How can you suggest something like that? :wink:

<whisper>I’ve tried the Fedora 13 live CD and the graphics performance seems to be slightly better, but this is just an eye-ball benchmark. It seems to have no 3D support, like in OpenSuse 11.3, so this is no major improvement…</whisper>