Radeon Driver (OSS) Tweaks?

I am running openSUSE 11.1/KDE 4.2.0 on a Dell D531 with an ATI Radeon X1250 card. For several months I have been using the fglrx driver from radeon. However, performance was severely lacking; just recently, another ATI/KDED4 user informed me that the OSS Radeon driver was working much better for him than the fglrx driver, so I figured I’d give it a try. I reconfigured my hardware with sax2 -r -m 0=radeon.

So far, it’s working fine, but there’s no hardware acceleration. I keep hearing conflicting reports on this. Some say the radeon driver does not support 3D, others (like the guy I mentioned above) say it works fine.

Does anyone know the current status of the radeon driver? Does it support 3D or not? I suspect it may, because the Kubuntu LiveCD runs KWin effects just fine, and I don’t think they included the non-free fglrx on the LiveCD.

And if radeon does support 3D, does anyone know of applicable tweaks to make in xorg.conf for better performance?


Okay, now I’m really confused. In my xorg.conf I have the following for the device:

Section "Device"
	Identifier  "Device[0]"
	Driver      "radeon"
	VendorName  "ATI"
	BoardName   "Radeon X1200"
	Option	    "DRI"
	Option	    "monitor-PANEL" "Monitor[0]" 
        Option      "RenderAccel" "on"
        Option      "AccelMethod" "EXA"

Looks okay. But lspic -vv returns the following entry for my card:

01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series] (prog-if 00 [VGA controller])                                                                                                
        Subsystem: Dell Device 0206                                                                      
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-                                                                                                     
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-                                                                                                      
        Latency: 64, Cache Line Size: 64 bytes                                                           
        Interrupt: pin B routed to IRQ 19                                                                
        Region 0: Memory at e0000000 (64-bit, prefetchable) [size=256]                                  
        Region 2: Memory at fe9f0000 (64-bit, non-prefetchable) [size=64]                               
        Region 4: I/O ports at ee00 [size=256]                                                           
        Region 5: Memory at fea00000 (32-bit, non-prefetchable) [size=1]                                
        Capabilities: [50] Power Management version 2                                                    
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)               
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-                                              
        Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-                  
                Address: 0000000000000000  Data: 0000                                                    
        **Kernel driver in use: fglrx_pci**[/size][/size][/size] 

What’s going on here?[/size]

You must reinstall Mesa.

You didn’t mention uninstalling the fglrx driver. You must do that as i think it interferes with the opensource one.
For your card, RS690, i think you can use either the “radeon” or the “radeonhd” driver. I was under the impression that the radeonhd driver was the recomended one for chipsets >R500, but according to this webpage X.Org Wiki - RadeonFeature they are in the same state.
You can always try and see which one works better. No 3d acceleration yet for your card though.