Radeon 6470M - The problem with latest ATI proprietary driver on openSUSE 12.1 64-bit

Hi all,

My laptop is HP 4530s with switchable graphics: a integrated Intel HD3000 & a discrete Radeon 6470M. I have installed the openSUSE 12.1 64-bit on this machine. Everything was okay until I had decided to install the AMD proprietary driver for the Radeon 6470M card.

It is said that the installation was successful. But when I reboot my laptop (after I ran aticonfig --initial with root privilege), I got the terminal mode logon prompt, instead of the KDM. I can boot into failsafe mode.

The output of the:

lspci -nnk | grep VGA -A2


00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
        Subsystem: Hewlett-Packard Company Device [103c:167d]
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] [1002:6760]
        Subsystem: Hewlett-Packard Company Device [103c:167d]
        Kernel driver in use: fglrx_pci

And the content of 50-device.conf file is:

#Section "Device"
#  Identifier "Default Device"
#  #Driver "radeon"
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
#  #Option "monitor-DVI-0" "Default Monitor"

I don’t want to reinstall the openSUSE, so is there any solution for this problem?

Thanks for your help!

The above result is when my laptop is in FailSafe mode. And when I logon at terminal mode, the result of lspci… is both “Kernel driver in use”, i915 for Intel and fglrx_pci for Radeon. Sorry for my carelessness.

Uninstall the ATI driver & remove the operating system, too. I am so disappointed with openSUSE 12.1!

Dual graphic cards (of different manufacturers) in one PC is very difficult for GNU/Linux in general and not just openSUSE. The PC manufacturers are not contributing to the effort to solve this difficulty for GNU/Linux. Instead there are some open source projects which are making an effort to solve this. Did you check out the ‘bumblebee’ project (or vgaswitcheroo) ?

Further to my post, we are fortunate that a user with both nVidia and Intel graphic cards (hybrid graphics) wrote a guide: http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/469244-bumblebee-optimus-support-howto.html but we have not had a user with both radeon and Intel graphic cards (in same PC) to write a guide, and we need someone to do so.

As oldcpu mentioned, we really could use some help from those who have switcheable Intel/AMD graphics, and are willing to experiment a bit, and create a guide. Anyway, for Intel/Radeon graphics systems, the vgaswitcheroo kernel support is the means by which the cards can be switched. I think Ubuntu leads the way here with development.

I don’t pretend to have the answer here, but this thread may offer you the insight needed to get your Radeon chipset supported with the proprietary driver. It is essential to make sure the radeon driver is disabled, and blacklisted. So, you grub boot entry needs to contain ‘radeon.modeset=0’, and IIRC, there should be a file ‘/etc/modprobe.d/50-fglrx.conf’ which contains ‘blacklist radeon’ entry.

The following page may be helpful with respect to switcheable graphics:


I was having the same problem with my switchable graphics cards Intel/ATI 5600, I used Linux Crew Driver Feedback to tell AMD about my problem and they fixed it in 11.5!

Well done Vengenz! A question: Are you using vgaswitcheroo to switch graphics?

Hi all,

Thanks for your replies. My laptop is HP Probook 4530s. In the HP official website, there are 2 graphics drivers for Novell SUSE Linux Enterprise Desktop:
AMD Radeon HD 6470M & Intel HD Graphics drivers
I don’t know that these drivers support switchable graphics or not. My laptop is dual boot with Microsoft Windows 7. Whenever I boot into openSUSE, I have to disable the discrete graphics in the BIOS. It’s too annoyed.

@Vengenz: Which version of openSUSE are you using?