RabbitVCS isn't working

On OpenSuse 12.1, rabbitvcs is showing two issues

  1. when I tried to run through the command line I got this:
    user@place:~/Dropbox/ufmg$ rabbitvcs commit repository
    user@place:~/Dropbox/ufmg$ Traceback (most recent call last):
    File “/usr/lib/python2.7/site-packages/rabbitvcs/ui/commit.py”, line 435, in <module>
    window = commit_factory(paths, options.base_dir, message=options.message)
    File “/usr/lib/python2.7/site-packages/rabbitvcs/ui/commit.py”, line 426, in commit_factory
    return classes_map[guess[“vcs”]](paths, base_dir, message)
    File “/usr/lib/python2.7/site-packages/rabbitvcs/ui/commit.py”, line 229, in init
    self.vcs.svn().get_repo_url(self.base_dir)
    AttributeError: Dummy instance has no attribute ‘get_repo_url’
  2. It is not showing the shortcuts in the context menus

Any idea how to solve this problem? Thanks in advance

Please, to make it readable to others, copy/paste your compuuter session parts you want to show between CODE tag: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html

And this should include your prompt, the command(s) you gave (you did that allready) and of course the output you got. This will not only preserve the lay-out of the original, but also make a clear difference between computer facts and story.

To begin with, I only have openSUSE 11.4 here, not 12.1, thus I may be wrong on this.

But I can not find a package rabbitvcs in the standard repos. When the same is true for 12.1, you should at least have explained where you have that product installed from. The more where your problem may point to incompatable product versions and thus dependancies may be important.

Ok, sorry for the missing code flags, thanks for the tip.

I never installed openSUSE before, so I started with 12.1.

The repository was Index of /repositories/devel:/tools:/scm/openSUSE_12.1 and I think it is official.
I installed as explained here http://wiki.rabbitvcs.org/wiki/install/opensuse, so this should be compatible, since the repository is for 12.1.