R Studio for data science programming in R language not installing

My first experience with switching to openSuse Tumbleweed was great until I tried installing resources for R programming, in particular R Studio (https://www.rstudio.com).
After reviewing some threads on this to try to figure out what is going on I summarize the problem.

Two questions:

  1. can anyone help met to make the latest RStudio work under Tumbleweed?
  2. how/where do I report this so I can contribute to the development of Tumbleweed?

Data Science is an exploding field, R is one of the two major programming languages and R Studio THE IDE to work with. I believe it would be a great feature for openSUSE to support it.


I managed to install R-base package to start with, but the issue lies with installing R Studio. I tried two ways.

A) I tried installing through software.opensuse.org which lists R Studio version 0.98.501 as unstable package for Tumbleweed (https://build.opensuse.org/package/show/devel%3Alanguages%3AR%3Areleased/rstudio)
During install I get the error:

YaST2 conflicts list - generated 2017-12-02 17:04:09

nothing provides libboost_date_time.so.1.54.0()(64bit) needed by rstudio-0.98.501-1.50.x86_64

 ] do not install rstudio-0.98.501-1.50.x86_64

 ] break rstudio-0.98.501-1.50.x86_64 by ignoring some of its dependencies

YaST2 conflicts list END

When ignoring the dependency nothing happens when trying to start R Studio.

B) I tried downloading the latest version from the official project page (https://www.rstudio.com/products/rstudio/download/#download) version 1.1.383 which states supported platform openSUSE 13.1+
When trying to install that I geth the following error:

"Package rstudio is broken, integrity check has failed.
Error: INVALID:rstudio-1.1.383-1.x86_64 (file-b5fb7e47): Signature verification failed [6-File is unsigned]
Header SHA1 digest: OK (d7fc3405fb1f13ef76743892d79c02eaf17312fc)
MD5 digest: OK (c0c7e0bd821ef9ffad6da094ab2c8911)

 Package is not signed!"

Ignoring that finishes the installation succesfully, but then trying to start RStudio again has no effect.

Can anyone help? Thanks!!

Without actually trying to install this version R Studio,

SOP for finding files/libraries/packages

  • Use the following zypper command
zypper se --provides *missing_file *

Lastly, depending on how desperate you may be for the file, do a search at rpm sites like rpmfind.net and rpm.pbone.net.
You can also try using a Fedora package which can work if that package in turn doesn’t have dependencies.

When a package either doesn’t have a signature or has a faulty signature, install ignoring the signature requirement as follows

rpm -i --nosignature *packagename *

If you still have a problem, repost.


HI TSU, thanks so much for helping out.

so I tried both options.

running the Zypper command on the RStudio RPM gives:

Loading repository data…
Reading installed packages…
No matching items found.

When running code:

rpm -i --nosignature *packagename*

I get the following error: “error: can’t create transaction lock on /usr/lib/sysimage/rpm/.rpm.lock (Permission denied)”

So I went a different route. I searched for the missing libboost_data_time packages on software.opensuse.org and found them for Leap 42.2 and installed them. Then I tried installing the older RStudio from the repositories (0.98.501), which gave no errors this time.

BUT, when I try to start RStudio; nothing happens. Any idea how I can debug that?

The thing is this is similar behavior as when I installed the latest version from the developer website and ignored the signing error. I can install rstudio package using Yast and ignore the signature error. It will show up as an installed package, but it wont run. Can the signature problem prevent it from starting correctly?

Any ideas how I can figure this out? Right now it looks like I might have to change Linux distribution to be able to run RStudio … but I liked the start of openSUSE Tumbleweed so much and I find it hard to understand such an important tool is not supported. I cannot fix it but if I can provide the information for others to help fix it I am glad to contribute in that way!

When you run the rpm install command, you need to have elevated permissions (su or sudo) to avoid that error.

You’ll have to describe what you mean by starting the application,
If you start using a command in a console instead of using a menu shortcut, typically that will display any errors.


Having the same issue with libboost_date_time_66_0.

Tried installing libboost with zypper, yast2 and from rpm files including fedora packages (everything as above) but nothing is working, i get the same missing dependency error. I will also have to switch distro in order to use RStudio…

Has anyone solved this yet? Or any idea of what I can try?

Hi, welcome

Please do not reuse old threads, specially on TW things change fast. Start a new thread, provide as much info as possible, post output between CODE tags, the # in the editor layout.
DO NOT use packages from other distros, chances of borking your system are real. And dependency errors will arise easily since not all distros use the same package naming conventions.

Old thread responses generally conform to the original Poster’s responses and may be affected by whatever was current at the time.

After a long period of time, circumstances can change which might affect responses.

Aside from that,

  1. The question always has to be asked where you’re installing your application from. Are you installing from the "devel:languages:R:released " which is what likely would have happened if you found your RStudio at the following?


  1. As long as you found this thread, I posted above several ways to find a file, library or dependency you need. Have you tried each method, and if you did what was or were the exact results?

Looking forward to your new Forum thread if you continue to have problems.