"quiet" parameter makes machine crash.

Hi all,

I have an intriguing problem when booting openSUSE 13.2 :

Booting is OK until the Grub boot screen. The grub screen proposes the two usual options (“normal” and failsafe modes) + windows.
Whenever I chose the normal mode, the machine would start the post grub boot process booting and then simply crash - but failsafe booting works.
By" crash" I mean that the machine just sits there, sometimes with a black screen, sometimes with some things written all across the screen.

By a process of trial and error I was able to work out that the “quiet” parameter seems to be the culprit : when I leave it out, the machine boots OK.

Here’s the corresponding line in the grub2/grub.cfg file (from which I already removed the quiet parameter)


    linuxefi /boot/vmlinuz-3.16.6-2-desktop root=UUID=7a08150c-d18d-48a7-8ebb-8bc9e370f0ea ro   resume=(...)  splash=silent showopts

If I add the “quiet” parameter back in, it crashes again…
Any ideas why this would be happening, or how I could find out what’s happening?

Thanks in advance.

Lenwolf

On 2014-12-07 12:06, lenwolf wrote:

> If I add the “quiet” parameter back in, it crashes again…
> Any ideas why this would be happening, or how I could find out what’s
> happening?

Try disabling plymouth.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Thanks, I’ll try that once I’ve figured out how to do that. Regards Lenwolf

On 2014-12-07 16:06, lenwolf wrote:
> robin_listas;2681328 Wrote:

>> Try disabling plymouth.

> Thanks, I’ll try that once I’ve figured out how to do that.

As I don’t like it, I remove the package completely, which makes the
initrd image smaller (it is important when /boot is a separate small
partition).

But otherwise, you can try the boot option “plymouth.enable=0”.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I’m interested in taking out plymouth, just wondering what it’s
going to look like.:\

On 2014-12-07 21:56, conram wrote:

> I’m interested in taking out plymouth, just wondering what it’s
> going to look like.:\

Beautiful text, hundreds of beautiful text lines flowing by :wink:

But in this case, the idea was to keep the quiet option, disable
plymouth, and see if it hangs or prints some error.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Yay! My machine boot time is 5-7 seconds, will I still see those hundreds of text?

On 2014-12-08 02:56, conram wrote:
>
> robin_listas;2681446 Wrote:

>> Beautiful text, hundreds of beautiful text lines flowing by :wink:

>
> Yay! My machine boot time is 5-7 seconds, will I still see those
> hundreds of text?

You need some dozens of hundred euros fast reading training sessions :-p

Or a video camera with slow replay.

No, seriously, when you are used to them, you can notice that something
unexpected went by, then you seek it in the logs. Sometimes the flow
stops for an error, then you can read it with more ease.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Sorry for my late answer.

Thank you robin_listas.
Unfortunately, that makes no difference.
The last displayed message I see is “OK reached target graphical system” or something similar.

This is a machime with dual graphics chips (Intel + Nvidia), normally Linux only uses the Intel one.

WHich log file(s) would contain info on this incident?

Thanks again.
Lenwolf

Hi,

Is there a way in the bios to check which is the bootable graphic card.
My machine has this in the bios to set which card is bootable.
If you are not using both cards you can disable the card you are not using
This way, maybe someone will be able to help you diagnose because it might be the graphic card is causing this issue.

On 2014-12-08 14:46, lenwolf wrote:
>
> Sorry for my late answer.
> robin_listas;2681363 Wrote:
>>
>> (…)
>>
>> But otherwise, you can try the boot option “plymouth.enable=0”.
>>
>>
>
> Thank you robin_listas.
> Unfortunately, that makes no difference.
> The last displayed message I see is “OK reached target graphical system”
> or something similar.

Ah, but that is interesting!

> This is a machime with dual graphics chips (Intel + Nvidia), normally
> Linux only uses the Intel one.

And this nails it.

You probably have a video driver problem. Linux tries to get into
graphical mode, and fails. You can probably boot just fine in text mode.
Maybe just hitting “enter” would give you a text prompt.

The setting of dual nvidia-intel is complex, I understand. You need to
ask/search specifically about it. I think the name is bumblebee. There
is a wiki link with instructions somewhere at opensuse.org, and some
threads here, too. I don’t have such a hardware, so I can hardly guide you.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Thanks robin_listas and conram.

I’ll check out the bumblebee. I haven’t found a way to switch off one graphics card in the Bios.

Still, and this is why I didn’t mention the dual graphics card right away, I can’t figure out why the machine only crashes when I leave the “quiet” parameter in. What does that parameter do?

Thanks

Lenwolf

On 2014-12-09 06:46, lenwolf wrote:
>
> Thanks robin_listas and conram.
>
> I’ll check out the bumblebee. I haven’t found a way to switch off one
> graphics card in the Bios.
>
> Still, and this is why I didn’t mention the dual graphics card right
> away, I can’t figure out why the machine only crashes when I leave the
> “quiet” parameter in. What does that parameter do?

It goes into graphical mode, if it can. In verbose mode it prints
messages in text mode instead. I didn’t see the relation earlier.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

No, unfortunately there isn’t, I checked. Thanks Lenwolf

So it’s a pretty safe assumption that if, at that time it tries to go into graphical mode, then it crashes. Strange that in verbose mode it doesn’t crash when it goes into graphical mode later for the login screen- but then, that is no longer plymouth but KDM, I presume? Thanks Lenwolf

Hi,

OK, I made some more investigations and it turns out that the culprit was plymouth as you suspected from the beginning, robin_listas.

I removed it entirely, rebuilt the init rd and rebooted : The “quiet” parameter no longer had any incidence on the boot process, the machine booted ok.

I then reinstalled plymouth, remade the init rd and rebooted. Bang the machine hung again. Removed the quiet parameter and it works.

Thanks for pointing that out to me. I wonder what plymouth hiccups on…

Lenwolf

Did you say what you video hardware is and if any special driver is installed?

Yes, an Intel Haswell chip with integrated GPU and an NVIDIA GPU. I did not install any kind of video driver myself. This is stock 13.2 x64. I believe the chip actually being used is the Intel one, but I could be wrong. I cannot chose which to use in the bios/efi. Regards Lenwolf

I wondered because Plymouth does funky stuff with the video. Intel should be about as vanilla as you can get.

Hi,
I have a post on top asking about the plymouth
I removed all plymouth then I agained a bit in reducing boot time.:slight_smile: