Quick Fix for Wireless Network Auto connect Issues 12.2

These Steps worked for me on four different laptops, one Acer, one Dell and two HP’s. The steps in this how to come from other members which I have sourced.


The following worked for me when using the Network Manager in KDE,

**1. **Right mouse click over the network manager icon in the system tray and
select Network Manager Settings

**2. **In the Configure - KDE Control Module select the Wireless tab
–(if no entry is showing you will have to setup a new connection)

  • then select your interface under the Connection header
  • then select edit
  • then make sure each of the boxes are ticked under Connection name,
    – Connect automatically and
    – System connect
    then press ok

**3. **If using the KWalletManager you will need your password for it and root
password to complete the changes

that’s it

if you are using the gnome desktop or network Traditional Method with ifup,
the above will not help

Source Post

Image of “Connect automatically” and “System connect” Check Boxes as they should appear when your done.


Image Sourced from Caf4926 post on this subject.

Please let us know if this works for you and on what hardware. If it doesn’t work for you, forum members will be happy to help you in the wireless support section of this forum.

Much Thanks to Caf4926 and keellambert.

Thanks lol!!
I also had the problem that the auto connection was not working and the wanted WLAN was not shown. Only when I disabled auto connection, the WLAN net was shown and I was able to click on the desired WLAN to start it.

Now, the WLAN connection will be directly established :-).