Questions on setting video mod into kernel automatically and 2 failed to start LSB on boot up msgs

Hello:

I just upgraded to Leap 42.2 from 13.2, but hit problems. I am having 2 LSB failures on boot up, should I be concerned?

OK ] Reached target Switch Root.
Starting Switch Root…
[FAILED] Failed to start LSB: Set default boot entry if called.
See ‘systemctl status cycle.service’ for details.

OK ] Started udev Kernel Device Manager.
Starting LSB: Set default boot entry if called…
[FAILED] Failed to start LSB: Set default boot entry if called.
See ‘systemctl status cycle.service’ for details.

But I need the most help with getting the “radeon” kernel module loaded upon boot up. It is NOT being loaded and then Plasma 5.8.6 defaults to the highest frame buffer size which is 1400x1050 which is totally incorrect for my system and my monitor and Sapphire ATI HD 5450 Radeon Graphics card.

How do I get the radeon kernel module to autoload?

To fix the radeon module, I added a “modprobe radeon” line to the /etc/init.d/boot.local file and then added a line “MODULES_LOADED_ON_BOOT” to the /etc/sysconfig/kernel file, but I am NOT sure if this is the correct way to proceed. It did work okay on a reboot try.

I guess I consider this question closed.

Actually it is only 1 failure, i.e. both are the same.

OK ] Reached target Switch Root.
Starting Switch Root…
[FAILED] Failed to start LSB: Set default boot entry if called.
See ‘systemctl status cycle.service’ for details.

So, what does “systemctl status cycle.service” say?

In the end you shouldn’t have to worry about that one.
Its purpose is to reset the default boot menu entry that will be booted, to prevent the boot menu from disappearing if grub2 cannot write to /boot/ and a temporary one is set via grub2-once or grub2-reboot, what is done e.g. if you hibernate.
(only the case if /boot is on an LVM I think, it shouldn’t be needed at all normally).

Btw, on my 42.2 system:

systemctl status cycle.service
● cycle.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

I.e. I don’t even have it installed. IIANM it’s in the package “bootcycle”, so you may want to uninstall that if the errors bother you.

How do I get the radeon kernel module to autoload?

Actually it should be loaded automatically.
Unless you specify “nomodeset” or “radeon.modeset=0” in the boot options.

What does “cat /proc/cmdline” say?

MODULES_LOADED_ON_BOOT is not respected at all in current versions (at least since 13.2, maybe earlier).
Running “modprobe radeon” in /etc/init.d/boot.local should work, but is not the preferred solution either.

If you want to explicitly load a kernel module on boot, specify it in a *.conf file in /etc/modules-load.d/, see also “man modules-load.d”. Or add something like “modules-load=radeon” to the kernel command line.

But, as mentioned, the radeon module should be loaded automatically if a supported card is detected (like any other “driver” actually).