question: how to mount W95 Ext'd (LBA) partition

i’ve googled everywhere, but to no avail. I would appreciate it if somebody can help, cos I would really to save my files on the W95 Ext’d (LBA) partition. So, my question is, how can I mount the above partition.

for ex:
fdisk -l gives
Device Boot Start End Blocks Id System
/dev/sdb1 1 19122 153597433+ 7 HPFS/NTFS
/dev/sdb2 19123 48640 237103335 f W95 Ext’d (LBA)
/dev/sdb3 19123 48640 237103303+ 7 HPFS/NTFS

as seen above, all I can say is sdb2 is my c:drive in windows and sdb3 is my d:drive. I hv no problem mounting sdb3. My main concern is that I cannot mount sdb2. I’ve tried

mount -t ntfs-3g /dev/sdb2 /mnt/ntfs1

but then it returns,
NTFS signature is missing.
Failed to mount ‘/dev/sdb2’: Invalid argument
The device ‘/dev/sdb2’ doesn’t have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

then,
mount -t vfat /dev/sdb2 /mnt/ntfs1
mount:wrong fs type, bad option, bad superblock on /dev/sdb2,
missing codepage or helper program, or other error
(aren’t you trying to mount an extended partition,
instead of some logical partition inside?)
In some cases useful info is found in syslog - try
dmesg | tail or so

can somebody tell me? ohh btw, I’m a linux n00b :stuck_out_tongue:

An extended partition is just a container. You don’t actually mount it, you mount the logical partitions inside it. If you look at the cylinder map, you will see that it contains the NTFS logical partition. So you’ve already succeeded, it’s the “D” drive.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Your partition table looks either wrong, or corrupt. For future posts
please don’t make things bold. Entirely bold sentences are considered
yelling/shouting, which is rude, though I doubt that was your intent.
Aldo commands in computers are case-sensitive (as are
files/directories/etc.) so case sensitivity is important and makes all
your commands incorrect.

So the problem with your partition table… sdb2 and sdb3 both have the
same starting and ending block, which is not normally valid. Also as
the message states ‘sdb2’ looks like an extended partition. If that’s
the case then the next partition can have the same boundaries, but it
should NOT be ‘sdb3’ but should be something like ‘sdb5’. Perhaps what
you typed is a typo and that would explain everything. If that is the
case try mounting the real number you were given and it should work. In
the meantime trying to mount an extended partition at all will fail as
it is not a place in which files are directly placed.

Good luck.

elyasn wrote:
> i’ve googled everywhere, but to no avail. I would appreciate it if
> somebody can help, cos I would really to save my files on the W95 Ext’d
> (LBA) partition. So, my question is, how can I mount the above
> partition.
>
> for ex:
> FDISK -L GIVES
> DEVICE BOOT START END BLOCKS ID SYSTEM
> /DEV/SDB1 1 19122 153597433+ 7 HPFS/NTFS
> /DEV/SDB2 19123 48640 237103335 F W95 EXT’D (LBA)
> /DEV/SDB3 19123 48640 237103303+ 7 HPFS/NTFS
>
> AS SEEN ABOVE, ALL I CAN SAY IS SDB2 IS MY C:DRIVE IN WINDOWS AND SDB3
> IS MY D:DRIVE. I HV NO PROBLEM MOUNTING SDB3. MY MAIN CONCERN IS THAT I
> CANNOT MOUNT SDB2. I’VE TRIED
>
> **MOUNT -T NTFS-3G /DEV/SDB2 /MNT/NTFS1
>
> but then it returns,
> NTFS signature is missing.
> Failed to mount ‘/dev/sdb2’: Invalid argument
> The device ‘/dev/sdb2’ doesn’t have a valid NTFS.
> Maybe you selected the wrong device? Or the whole disk instead of a
> partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
>
> then,
> MOUNT -T VFAT /DEV/SDB2 /MNT/NTFS1
> mount:wrong fs type, bad option, bad superblock on /dev/sdb2,
> missing codepage or helper program, or other error
> (aren’t you trying to mount an extended partition,
> instead of some logical partition inside?)
> In some cases useful info is found in syslog - try
> dmesg | tail or so
>
> can somebody tell me? ohh btw, I’m a linux n00b :stuck_out_tongue:
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI6O0A3s42bA80+9kRAl//AJ0eAcSY5N8VgUiWy1RhJAB3xXmBNgCfaegI
eGXku4T2gq7CavFaPEYbyFc=
=GhXf
-----END PGP SIGNATURE-----
**

Hi
Your confused and trying to mount the extended partition, you need to
mount either sdb1 (C drive) or sdb3 (D drive) :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 2:10, 1 user, load average: 0.03, 0.19, 0.24
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

**

i’m sorry, my bad… typo in pasting the returned command

fdisk -l gives
Device Boot Start End Blocks Id System
/dev/sdb1 1 19122 153597433+ 7 HPFS/NTFS
/dev/sdb2 19123 48640 237103335 f W95 Ext’d (LBA)
/dev/sdb5 19123 48640 237103303+ 7 HPFS/NTFS

if that’s true: by mounting the D:drive I managed to mount the logical partition. Why am I not seeing my files in C:drive? folders like C:program files, C:windows, desktop folder, etc.?

btw,

i tried mounting sdb1… but failed.

linux-bgjt:~ # mount -t ntfs-3g /dev/sdb1 /mnt/ntfs2
ntfs_attr_pread: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or you have hardware faults, or you have a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows TWICE. The usage of the /f parameter is very
important! If you have SoftRAID/FakeRAID then first you must activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for the details.

ok… feels like i’m in deep trouble…

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Have you tried mounting /dev/sdb1? That’s probably what windows maps to
your C drive.

Good luck.

elyasn wrote:
> i’m sorry, my bad… typo in pasting the returned command
>
> fdisk -l gives
> Device Boot Start End Blocks Id System
> /dev/sdb1 1 19122 153597433+ 7 HPFS/NTFS
> /dev/sdb2 19123 48640 237103335 f W95 Ext’d (LBA)
> /dev/sdb5 19123 48640 237103303+ 7 HPFS/NTFS
>
> if that’s true: by mounting the D:drive I managed to mount the logical
> partition. Why am I not seeing my files in C:drive? folders like
> C:program files, C:windows, desktop folder, etc.?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI6PZE3s42bA80+9kRAgdJAJsHOKIuAWunVHlDtdtgB/PzG51JgQCdFx+x
mSJ7RhK5cnFFnlt8fcsx7PM=
=Pffx
-----END PGP SIGNATURE-----

i tried mounting sdb1… but failed.

linux-bgjt:~ # mount -t ntfs-3g /dev/sdb1 /mnt/ntfs2
ntfs_attr_pread: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or you have hardware faults, or you have a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows TWICE. The usage of the /f parameter is very
important! If you have SoftRAID/FakeRAID then first you must activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for the details.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

And did you follow those instructions?

Good luck.

elyasn wrote:
> i tried mounting sdb1… but failed.
>
> linux-bgjt:~ # mount -t ntfs-3g /dev/sdb1 /mnt/ntfs2
> ntfs_attr_pread: ntfs_pread failed: Input/output error
> Failed to read NTFS $Bitmap: Input/output error
> NTFS is either inconsistent, or you have hardware faults, or you have
> a
> SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
> then reboot into Windows TWICE. The usage of the /f parameter is very
> important! If you have SoftRAID/FakeRAID then first you must activate
> it and mount a different device under the /dev/mapper/ directory,
> (e.g.
> /dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
> for the details.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI6P0J3s42bA80+9kRAmg0AJwNZrUchb01qxDNmfEMJg2ONChYdgCeLDX7
gqQ++FXHJc0egJTaavGxbHY=
=8ct+
-----END PGP SIGNATURE-----

honestly, at a glance, I don’t understand a thing… about fakeRAID/softRAID, but i’ll do what I can tomorrow since it’s getting late here… :Z

My memory may be wrong about this, but it wouldn’t hurt . . . try mounting the partition with just “ntfs” rather than “ntfs-3g”. IIRC the former uses the old driver which is read only. This would verify that the partition is at least mountable.

Do you have bootable Windows media such as an installation CD? That would enable you to verify the partition, the filesystem, and as the above error message recommends, to run a repair check on the file system.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Well, I was referring to the first part of the message where it
recommends using chkdsk in windows in case there os some damage to the
partition. If you don’t know what RAID is then you’re not using it.

Good luck.

elyasn wrote:
> honestly, at a glance, I don’t understand a thing… about
> fakeRAID/softRAID, but i’ll do what I can tomorrow since it’s getting
> late here… :Z
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI6QYQ3s42bA80+9kRAoNKAJ9i5k/BzSBJrkEAx6D3lXBrZe66PgCeNw/P
I6/o0guJZ0STzg5uhHzKvGM=
=i10d
-----END PGP SIGNATURE-----

Fascinating clash of cultures and/or generations. We young folk who use the newer technology of the web interface weren’t aware of that and mostly use bolding to isolate segments of text for special reference.

it looked OK, it seemed to mount. but when I do that, it is hanging up my machine. I could barely click on anything after mounting it. The machine is responding slowly. Furthermore, it seems that there’s an ‘X’ emblem on the mount path folder icon if I managed to browse to that folder. As if I hv no permission on that folder.

So, ur suggestion is to run a repair check on that partition using windows installation media? I’ll try that one, but I need to find the cd first… :)… it’s been a while

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Not necessarily from the install media… windows has this utility when
installed as well.

Good luck.

elyasn wrote:
> mingus725;1879796 Wrote:
>> My memory may be wrong about this, but it wouldn’t hurt . . . try
>> mounting the partition with just “ntfs” rather than “ntfs-3g”. IIRC the
>> former uses the old driver which is read only. This would verify that
>> the partition is at least mountable.
>>
>> Do you have bootable Windows media such as an installation CD? That
>> would enable you to verify the partition, the filesystem, and as the
>> above error message recommends, to run a repair check on the file
>> system.
>
> it looked OK, it seemed to mount. but when I do that, it is hanging up
> my machine. I couldn’t click on anything after mounting it. Furthermore,
> it seems that there’s an ‘X’ emblem on the mount path folder icon if I
> browse to that folder.
>
> So, ur suggestion is to run a repair check on that partition using
> windows installation media? I’ll try that one, but I need to find the cd
> first… :)… it’s been a while
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFI6Vk13s42bA80+9kRAgJFAJ9SoScO6pWqtwUVShDoqP9oTUJUVgCeJIsA
e87grMhWOI8Yhwg9ILrxx5g=
=UcDT
-----END PGP SIGNATURE-----

Yes. I assumed from the previous posts that you cannot boot into Windows. If you can, then of course run chkdsk from there (it can only be run from the command window). If not, it is on the W2K or XP installation media under the Recovery Environment. I doubt the Vista RE - which is downloadable - will operate on a non-Vista partition (even though the filesystem is the same).