Question about USB media write mode

In OpenSuse 10, I remember they had enabled synchronous write mode for usb devices, which meant that data was immediately written to the device and you didn’t have to manually unmount it when you wanted to pull the device off. In later versions, I noticed they disabled this feature.

I was wondering if this was also the case for Opensuse 11 and if it isn’t, how do I enable sychronous writing? I’ve always liked the way Windows handled usb devices better than Linux.

Bump bump bump

On Fri, 22 Aug 2008 17:06:02 GMT
Benjamin Xiao <Benjamin_Xiao@no-mx.forums.opensuse.org> wrote:

>
> In OpenSuse 10, I remember they had enabled synchronous write mode for
> usb devices, which meant that data was immediately written to the device
> and you didn’t have to manually unmount it when you wanted to pull the
> device off. In later versions, I noticed they disabled this feature.
>
> I was wondering if this was also the case for Opensuse 11 and if it
> isn’t, how do I enable sychronous writing? I’ve always liked the way
> Windows handled usb devices better than Linux.
>
>

If you wish a device to be mounted with the ‘sync’ option…

insert your device, allow dolphin/konqueror/whatever window to open

go to /media, RIGHT click on your device

Go to ‘Properties’

“Mounting Tab”

Select ‘Synchronous’.

That particular device will be mounted with synchronous writes in the future.

I’ve tried this with several usb-flash drives, the option needs to be enabled
for each drive, although once set, it will remain set for that device.

Loni


L R Nix
lornix@lornix.com

That’s odd. I do not have the Mount Tab. There is only General, Permissions, and Share

On Mon, 25 Aug 2008 17:06:01 GMT
Benjamin Xiao <Benjamin_Xiao@no-mx.forums.opensuse.org> wrote:

>
> That’s odd. I do not have the Mount Tab. There is only General,
> Permissions, and Share
>
>

Was it automounted, or did you mount it by hand? I was allowing the
usb-flash to be automounted.

Also, am using KDE 3.5.9.

Loni


L R Nix
lornix@lornix.com

Ah there’s the problem. I am using KDE 4.1, but it is still being automounted. I guess they haven’t ported that feature over yet. Or maybe there’s an extra package I can install?

I can’t find a package that would let me change mount options in KDE 4.1

Guess I ran out of luck.