Question about Nouveau and Nvidia

Hi again.

I’m finally installing openSUSE 11.4 x64, but there’s still a small doubt I have. By default installed graphics driver is Nouveau, and I read one should blacklist Nouveau first before installing Nvidia drivers. When I installed 11.3 I did it before knowing this and just added Nvidia repo and installed drivers, which seemed to “overwrite” Nouveau…

Now I intend to make a better installation. Is it harmful not having Nouveau blacklisted? I haven’t seen issues regarding Nouveau-Nvidia conflicts by now on 11.3… And for correct installation sake, how do I blacklist Nouveau?

Thanks.

On Tue, 26 Jul 2011 04:56:02 +0000, F style wrote:

> Now I intend to make a better installation. Is it harmful not having
> Nouveau blacklisted?

I don’t know if it’s supposed to be harmful, but I am running the nvidia
driver and did not blacklist nouveau on my x64 system, and things are
running just fine.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

F_style: yes nouveau must be blacklisted to stop him from starting when the OS loads. If you install the nvidia driver from the nvidia repo Yast will blacklist nouveau and adjust /etc/sysconfig, you just add the “nomodeset” option to the bootloader(the easy way). If you install it manually you will have to blacklist nouveau, add “nomodeset” option to the bootloader and adjust /etc/sysconfig/Kernel (a.k.a nvidia the hard way SDB:NVIDIA the hard way - openSUSE )

hendersj: if you had installed the nvidia driver from the repo it is blacklisted already. Personally if i leave nouveau “free” my system gets unusable. Better to be safe than sorry i say :slight_smile:

This is what I do:
nVidia Driver via Repo in 11.3 & 11.4 - Guide

When you install the nvidia driver from repo - for example using the command

zypper in x11-video-fglrxG02

The package nvidia-gfxG02-kmp-desktop (or -default) including the kernel module and the file /etc/modprobe.d/nvidia.conf is installed by dependencie.

# rpm -ql nvidia-gfxG02-kmp-desktop
/etc/modprobe.d/nvidia.conf
/lib/modules/2.6.37.1-1.2-desktop
/lib/modules/2.6.37.1-1.2-desktop/updates
/lib/modules/2.6.37.1-1.2-desktop/updates/nv-kernel.o
/lib/modules/2.6.37.1-1.2-desktop/updates/nv-linux.o
/lib/modules/2.6.37.1-1.2-desktop/updates/nvidia.ko

The file /etc/modprobe.d/nvidia.conf has the following content:

# cat /etc/modprobe.d/nvidia.conf
blacklist nouveau

It prevents the nouveau module to get loaded.

The situation is dynamic wrt the need to blacklist nouveau, and the situation is dynamic wrt the need to disable modesetting. Dependant on the nVidia proprietary driver version, and dependant on one’s exact hardware, one may or may not have to disable modesetting and one may or may not have to black list the nouveau driver. I know of no list explaining what is needed exactly for what hardware. Instead one needs to try their best.

The 4th thing to try in this guide gave some advice: SDB:Configuring graphics cards - openSUSE in the paragraph flagged with a ‘WARNING’ :

Warning Nvidia graphic card users who discovered that the “nouveau” driver did not work for them, should pay attention to the openSUSE-11.3 release notes and as appropriate blacklist the “nouveau” driver in the /etc/modprobe.d/50-blacklist.conf file. This can be done with root permissions by typing:

 
        echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

It may also be necessary to run "yast" (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to "yes". This takes a minute or two to save once changed is submitted.

Note that ‘echo’ with the ’ >> ’ symbol is a very dangerous command. If one mistakenly uses only ’ > ’ it over writes instead of appending to the file. So be VERY careful and be certain to use ’ >> ’ .

AFAIK you can use any filename (with extension .conf) in /etc/modprobe.d. The driver from repo adds nvidia.conf. So this command should do it to:

echo "blacklist nouveau" >> /etc/modprobe.d/nividia.conf

@F_style
Notice that in this case “>” would have been OK. I intentionally used “>>”, which is equivalent if the file doesn’t exist. So if you decide to follow @oldcpu’s suggestion - which is fine - I strongly second and highlight his warning:

When you’re done installing nvidia, you can check if nouveau has been blacklisted with this command:

grep nouveau /etc/modprobe.d/*

If it gives an output similar to this

/etc/modprobe.d/nvidia.conf:blacklist nouveau

you don’t need to blacklist it twice - although it shouldn’t matter.

Sorry (that would have been for the ATI driver) , I meant

zypper in **x11-video-nvidiaG02**

On Tue, 26 Jul 2011 07:16:02 +0000, creatura85 wrote:

> hendersj: if you had installed the nvidia driver from the repo it is
> blacklisted already. Personally if i leave nouveau “free” my system gets
> unusable. Better to be safe than sorry i say :slight_smile:

That would explain it - thanks!

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

From your guide, what are steps 2 and 3 for? Looks like I just did steps 1, 4, 5, and 6 back then…

It’s a sort of double barrelled approach to taking out nouveau

I did a install of 11.4 (KDE) for a friend today. He has a nVidia 9800GT.

By way of experiment. All I did was add the nVidia repo, then open software management. The correct packages were ready and waiting to be installed. I let it run, then rebooted. Working perfectly with nothing else to do. How easy is that!