Question about mounting a network filesystem

I want to mount a folder that exists on a XP box. The folder needs to be mounted to allow R/W for me the user.

I tried the following command

mount -t smbfs -o username=xpusername,password=xppassword  //fileserver/path/to/folder

The above doesn’t seem to work. The username on the XP box actually has a space in it as does do the folder names. Is this what’s causing the problem?

> The username on the XP box actually has
> a space in it as does do the folder names.

while waiting for a real network guru (i am NOT!), you can try this, i
don’t how it could hurt anything…

using your example (which i have NO idea if it should work or
not…BUT, if username is actually “user name” and the directory you
wanna mount is “folder name” then, try this:

mount -t smbfs -o username=‘user name’,password=xppassword
//fileserver/path/to/‘folder name’

and, if that doesn’t work, try this:

mount -t smbfs -o username=“user name”,password=xppassword
//fileserver/path/to/“folder name”

see, i think it is getting confused if you are now sending

mount -t smbfs -o username=user name,password=xppassword
//fileserver/path/to/folder name

/( )

Thanks. Neither of those worked. I’m not entirely sure the command is correct but that’s what I found with googling.

smbfs mount has been replaced by cifs mount in openSUSE. Much the same, slight diff in syntax. See here:
HowTo Mount a CIFS Network Share [AKA Mapped Network Drive] in openSUSE

Just to say I made a typo in my command above. I left the mount point off. It should be
mount -t smbfs -o username=xpusername,password=xppassword //fileserver/path/to/folder /mount/point/path Still not working though. Just trying to run this from the terminal as root.

Ah, thanks. I did see a reference to cifs when googling but didn’t know what it was so dismissed it. I’ll give that a try.

Ok, just looked at your tutorial. I can’t enable smbfs. I get an error saying " /etc/init.d/smbfs start returned 6 (program is not configured):"
I have samba-client installed and configured and can happily browse my XP box and all the files and folders on it.

What needs configuring? Do I need to set up the full blown samba server?

OK. Got it working. I started the smbfs using the terminal.

Just for interest, what mount did you finally use to get it working?

I used

chkconfig smbfs on

to start the smbfs service.
Then mounted with

mount -t cifs -o username=xpusername,password=xppassword //fileserver/path/to/folder /mount/point/path

The xpusername and some of the xpfolders had spaces in them so I wrapped then in " ".