Question about Kernel Source package

I have a question about the kernel source package. A kernel update is available for my 11.2 system. When this is done, the kernel version number will be different, won’t it? I have the kernel source package installed at the moment because I need it for installing my graphics card driver (NVidia G98 [GeForce 8400 GS])

After the kernel update, do I need to find a kernel source package update too, (they have to match versions, right?) or will the one I have be ok for re-installing my graphics card driver?

BTW, after the kernel update, will my display suddenly not work at all [blank screen] until I re-install the driver or will it continue to work but act weird like when xorg was updated? I’ve never done a kernel update before. (I had used SuSE 10.0 but by the time I had installed the NVidia driver for 3D graphics, whatever kernel update(s) had already been done so I never had experience this).

You need to keep kernel-source updated with the kernel

Next question: Should I install the “kernel-source” update before installing the kernel update or after that? I’m asking this because I don’t know what to expect (will my NVidia graphics card driver suddenly stop working entirely, leaving me with a blank screen? - If so, then what? Would I be able to tell xorg to use a generic graphics driver [is it vesa?] temporarily?)

I’ve just installed two kernel updates within the past week, one being just last night. In both cases, the updater was smart enough to download the kernel-source appropriate for the new kernel, install it, and install the proper nvidia driver rpm for my system. So by simply updating the kernel through the updater applet, or dirctly through Yast, it should be automatic.

Now the bad news. One time, a year or so ago, this did not work automatically, and so I had to download the kernel source, and nvidia driver myself, and do it manually. I’ve instructed Yast to save my previous kernels so I can choose which kernel to use at boot up, just in case. I then manually remove (rpm -e kernel-xxx) the third oldest kernel, once I’m satisfied the new kernel is working well.

The NVidia driver that I use is not the rpm one because that one does not support 3D the way the manually installed one does.

How do you tell Yast to save your previous kernels?

How do you tell Yast to save your previous kernels?

See this post
Keyboard & mouse freezes

I made the change to the zypper file as you said. (/etc/zypp/zypp.conf correctly, e.g.: multiversion = kernel-default – there’s not supposed to be a # in front of that, right?)

I don’t know if this is related or not but now I’m having trouble with the updater applet. It says the following when checking for updates:

PackageKit Error repo-not-available: Failed to download /repodata/repomd.xml from

PackageKit Error repo-not-available: Failed to download /repodata/repomd.xml from Index of /repositories/games/openSUSE_11.2

When I went into YaST and tried to get updates from there, it told me that there was a problem with /usr/bin/packagekitd. I even tried to find packagekitd but it’s not there.

I can’t do the kernel update without this now. :frowning:

I made the change to the zypper file as you said. (/etc/zypp/zypp.conf correctly, e.g.: multiversion = kernel-default
Correct if you use kernel-default
uname -a
will tell you your kernel type.

Remove the # is correct

Re: Packman @inode - Remove that repo it’s dead
Use this:

Games repo is OK as far as I know

ok, the kernel was multiversion = kernel-desktop. I pasted the wrong one in my reply.

uname -a gives:

Linux linux-oup0 #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 i686 i686 i386 GNU/Linux

The Online Update Configuration tool is now stuck. It is still looking for that repo in order to load the tool. How do I edit it now? It’s not letting me cancel it.

Edit: It finally allowed me to get to the Add Repository tool so I’ve now disabled the repository that went down and successfully added the new one.

I will try to do the update(s) maybe tomorrow or Monday because right now, I have a headache and I can’t concentrate too well.

Hope you feel better soon.

Thanks, I’m ok now, it must have been the heat that day.

Ok, now I applied the kernel update (and got only the black text screen like I was afraid of) so I made sure that I was in run level 3 (with root privileges), but when I went to re-install my graphics card driver, it wouldn’t work! It said, cnf! I even tried typing the command in again, making sure that I got it right but that still made no difference.

(This is what I did [in run level 3] : I changed to the directory where the driver installer is. Then I typed in the installer command: -k . Then I got that cnf message. I then tried it again without the -k but that still did not work.)

I managed to restart the computer (Boy am I Glad that you told me to tell Yast to show multi kernels!) and now I’m running in the older kernel. Then I checked in YaST to make sure that the new kernel-source package was installed, and yes it was. Then I made sure that the NVidia file was still in the directory that I knew it should be, and yes, it was still there.

The driver is:

I don’t understand, I was able to re-install this driver just fine after the xorg update but why won’t it install now after the kernel update? So now, I have an updated kernel but I can’t use it because the graphics card driver won’t install. So, now I have to still use the older kernel anyway. This is why I just hate updates! I’m just very upset at the moment. :frowning:

P.S. my graphics card is a GeForce 8400 GS Model 98

So you are installing the driver manually? Not from the nvidia repo? = Just to confirm

Yes, and I found out what my problem was: I wasn’t typing the “sh” at the beginning of the command. Stupid n00by mistake.

Before I discovered that, I went to the NVidia site and got a newer driver (The site let me choose the graphics card model # and then it came up with the driver so now, I’m using that one instead of the one I wrote about and I am now booted up in the newest kernel.
^^ ^^ ← (anime style happy faces)

I’m glad that you were here to help. :smiley:

I wasn’t paying attention. I kind of just assumed you already had a handle on it - or I would have posted a tutorial on it

Well I guess I did have a handle on it then. :smiley:
Tutorial? Where are such tutorials here? I know that in there’s a permanent link up on the navigation menu but I haven’t seen that here.
I’m now interested in getting Samba running. They seem to have changed things around with that from the previous SuSE version that I ran (10.0) so I’m used to those tools.

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.

Go to Yast>Software>Software Management

Search for and install if you don’t have these:


Now download the latest Nvidia driver:

Place the file in your /home/username

Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Login with your username and password

Now switch to super user with su
and root password

*Now remember you can use the {TAB} key to auto complete

so type:
and the whole file name should auto complete

eg: sh

Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

I’m very glad that you posted this. I didn’t know about the TAB auto complete. I was doing all the typing myself.
Also, I never knew how to pause the boot screen. I’m going to print this out for next time. :smiley:

Is the boot screen like this? (found by google-ing for “boot screen”) Initial Boot.png

That is a boot screen
One I posted actually