Question about GRUB2 boot-list item "UEFI Firmware Settings"

After upgrading the OS on an HP EliteDesk 800 G4 SFF desktop machine, using zypper, from openSUSE 15.3 to 15.4, the above new item appeared on the GRUB2 boot-list. The machine boots normally when “openSUSE 15.4” is selected. Selecting "UEFI Firmware Settings"causes the machine to reboot into the BIOS setup menu.
This boot-list item does not appear on other updated machines, but output from efibootmgr seems normal.
I am wondering whether this change is expected or whether it indicates a possible error.
Kind advice would be appreciated. Thanks.

This is a standard bootloader entry on UEFI machines. It eases the pain to hit the right key for BIOS whilst startup…

Nothing to worry about. All my openSUSE Tumbleweed installations show “UEFI Firmware Settings” in the GRUB2 boot menu.

If you do not want that list entry you can remove it as follows (as user “root”):

Remove (but first save!) the file /etc/grub.d/30_uefi-firmware (the file name on your system might be slightly different) and then run grub2-mkconfig -o /boot/grub2/grub.cfg. On the next reboot the list entry should be gone.

If you have more than one distribution on your machine the changes need to be done in the distribution which manages the GRUB2 instance used for booting.

Thanks for responding, hui + junky. Good to know.

This file is installed by the grub2 package, so if you remove it, file will be back after package update. Replace it with executable file that does exit 0 without any changes; on package update it will be preserved and the original file will get .rpmnew suffix. Files with this suffix are ignored by grub2-mkconfig.

Ooops, … Yes, I forgot about the GRUB2 package updates!

Thank you for correcting me!

Thanks. Could you kindly outline the suggested process?

cat > /etc/grub.d/30_uefi-firmware << EOF
exit 0
chmod a+x /etc/grub.d/30_uefi-firmware
1 Like