question about catalyst drivers, are they any good for anybody ?

amd phenom II X4 955 4 gig ram
HD 5750 1 gig ram

Yesterday I had to re install openSUSE 12.3

I had problems with uninstalling the Catalyst beta drivers 13.2 beta 3 , then used --force to un install, but that resulted in a not working openSUSE 12.3

After the re install of openSUSE, flash video’s in full screen were 100% fluently. I had no screen tearing when browsing websites.

Then I installed the catalyst driver ( through yast, by first adding the right repo )

Now I have again screen tearing, also in full screen flash vids, and flash video’s freeze for a sec frequently.

Because of gaming, the opensource drivers are sadly not an option, but they are much better with flash and Firefox.

From the steam for Linux forums, I know I am not the only one with these problems, but I am wondering, has anybody got them working right on Linux? ( openSUSE 12.3 64 bit)

I doubt I will ever buy and amd vid card though. That has been a disappointment form the start on Linux.

gaming is not used but my experience is given in

Thank you.

Maybe I should try again the beta driver, but this time in init 3 and deleting x org.

I managed to solve the freezing in flash.

System settings, desktop effects, disable effects for fullscreen.

And I have turned on V sync. ( in catalyst control center )
I will have to test if this causes issues in games.

But at least at the moment fire fox is as smooth as on windows 7, no tearing.

My understanding is the Catalyst drivers work well in openSUSE-12.2.

The version of X and the newer kernel in openSUSE-12.3 is causing problems with both nvidia and fglrx (catalyst) drivers. wrt fglrx (catalyst) there is nothing new there IMHO. Typically, going back as long as I ran remember in GNU/Linux, there has been a time lag before a new Catalyst driver was provided to support the latest and greatest version of X and of the kernel. As long as one does not insist on being on the cutting edge of the latest and greatest openSUSE release, indeed any GNU/Linux release, one can have the catalyst driver and play their games (such as on openSUSE-12.2).

My suspicion is it is mostly a matter of patience while waiting for a new fglrx version to hit the street for those with non-legacy AMD graphic hardware and with new versions of X and new versions of the kernel.

For now I am happy, after the second time this week of reinstalling opensuse 12.3

This time I did not install the latest beta drivers, and everything seems to be fine.

Steam start up without errors.

I am afraid you are right.

I can explain though, why I would want to try the latest beta drivers.
They have fixes for Teamfortress2 and serious sam 3.

Its not just because of the problems I have on Linux, windows is not that much better when it comes to gaming.

And before someone wants to argue that.

I tried installing grandprix 4 on windows 7, no luck, what ever compatibility mode I choose.
Star Wars republic command wont work either.
Area 51 , a free game which run fine on xp, will not work on W7.

There are days, I whish I was not interested in games.

Something about the release notes of the latest Catalyst 13.4 ( released today)

**Linux Distributions Supported:
**The latest version of the ATI Catalyst™ Linux Software Suite is designed to support the following Linux distributions:

  • Red Hat Enterprise Linux Suite 6.2 and 6.3
  • SUSE® Linux Enterprise 10 SP4 and 11 SP2
  • OpenSUSE 11.4 and 12.1
  • Ubuntu 12.10

Not even 12.2 according to AMD.


Thank god this is usual fixed by our openSUSE friends.

Installed Catalyst 13.4 yesterday on a AMD A3850 (built in 6530d GPU) and opensuse 12.3. Working fine for me. I don’t use my computer for games so i haven’t tested that.

Reply om my own post.

“are they any good for anybody ?”

Hell YES>:)! Big difference. Running 2 large monitors in opensuse 12.3(KDE) and earlier…(9.3).

-gives your computer a boost.
(I don’t want to kick on the free developers, they are doing a great job).
-configurations possibility as logged in as root, -amdcccle at Catalystcenter. No editing in xorg files manually. Works!